I have a NAS SMB share that I want to mount. It's not always on, and I use the same computer at work so I don't want to mount it automatically.

For now I mount and unmount it through terminal, but is there a way to make it behave like USB flash drive? And by that I mean, it mounts (or tries to mount) when I click on it (/media/nsa320/ folder) in Nautulis, and unmount when I click the eject button. Today I found users mount flag, I for a second I thought that was it, but I still can't mount it by clicking on it:

mount.cifs: permission denied: no match for /media/nsa320 found in /etc/fstab

I get the same output with: mount /media/nsa320/, so I guess that's what Nautulis is trying to do. From what I can tell the users flag only changes that you don't have to type your password, but you must still use the command as root. Weird. I can unmout the share through Nautilus though.

$ mount /media/nsa320/
mount.cifs: permission denied: no match for /media/nsa320 found in /etc/fstab
$ sudo mount /media/nsa320/ [works]
$ umount /media/nsa320/ [works]

For a long time I wanted to make it happen, but once more after looking for the answer fell short. Is there any way to achieve what I want?


//192.168.0.xx/xxx /media/nsa320/ cifs users,noauto,credentials=/home/xxx/.smbcredentials,uid=1000,gid=1000,file_mode=0655,dir_mode=0755,iocharset=utf8,sec=ntlm 0 0

Thanks, Paweł


You must log in to answer this question.

Browse other questions tagged .