11

I'm trying to install Ubuntu on my Nexus 7 (2012) Tablet, however, it appears that this tablet is no longer included in the official dev releases. I'm about half way through following the Porting to a New Device Guide and I'm just starting to realize how in-depth this project is about to become, so I was wondering if there was a way to find and install the last devel release for grouper.

This is the result that I got while following the install guide for Ubuntu Touch:

$ ubuntu-device-flash touch --channel=stable --device grouper --bootstrap

2015/06/08 12:48:59 Device is |grouper|
Device grouper not found on server https://system-image.ubuntu.com channel stable

I also tried this with devel as well. It makes sense that a uTouch build for Grouper is not in either of these channels, as it is no longer officially supported.

As I'm not against taking the time to learn how to do this properly, if there is not a way to access a build for grouper, does anyone have some good articles to read or advice from their attempts at doing these sorts of things? This will be my first major foray into development or trying something like this.

  • Have a look at this Installing Ubuntu Touch. – vembutech Jun 8 '15 at 14:07
  • 2
    still, there were severe problems with the graphics on the 2012 nexus 7 (one of the major reasons they stopped using it), I doubt even if you did the port right that it would work – Mateo Jun 8 '15 at 14:11
  • I did read that Installing Ubuntu Touch article, but given that it was also written in 2013, when the devel build for grouper was still available, it's advice of using "phablet-flash ubuntu-system –channel devel –no-backup" isn't going to help with this. Also, I guess I understand that this won't be without it's major issues, but I'm still going to try it. – SocksofGranduer Jun 8 '15 at 14:53
  • @SocksofGranduer Did you have any luck? I also have a Nexus 7 (2012) and would like to try out Ubuntu touch. – mote Nov 23 '15 at 9:40
  • 1
    I did not @Mote. I wrote out the list of things I would need to figure out how to do to perform the steps I would need to take. I'm still working on it, but I would say it's "two weeks out" – SocksofGranduer Nov 24 '15 at 13:02
7

Since yesterday I have on my Nexus 7 2012 desktop Ubuntu 14.04.3 LTS, so I think steps for reproduce this on Ubuntu Touch can be similar (or you can try desktop version).

So everything you doing on your own risk. :-)

My steps was in short this:

  1. Flash Ubuntu 13.04 via Fastboot (commands in previous answer)
  2. Edit file with repositories at /etc/apt/sources.list based on this examples (I choose Trusty because it is next LTS after 13.04 and I doesn't expect any problems)

    deb http://ports.ubuntu.com/ trusty main restricted
    deb-src http://ports.ubuntu.com/ trusty-security main restricted

  3. Make apt-get update and apt-get upgrade

  4. Optional: Install SSH server with apt-get install ssh

  5. Restart tablet and enjoy latest LTS version of Ubuntu :-)

Source: my today blogpost (in Czech)

  • 1
    What about the usability of Ubuntu Desktop 14.04 on Nexus 7? The github link from bseibold answer say that "The Unity Desktop Environment is very buggy, slow, and just not a good fit on the Nexus 7" – Jaime M. Mar 23 '16 at 23:23
  • hi thanks, well that seems neat I have bricked my tablet twice while doing this though... got the first update and upgrade right after editing the sources but then there are another update set that messes up the display so that i cannot login and wont find a way to open tty. gonna try setting up ssh for debug, thanks mate. – Yvain Jun 17 '17 at 0:41
  • @Yvain Hi, I don't remember anything about problems with display. Did you try connect USB keyboard or mouse via OTG USB? Did you install SSH before restart? Can you reach SSH port? I don't have N7 more than one year so I can't help you more than with those ideas.. – zorbon.cz Jun 18 '17 at 7:39
  • unfortunately i cannot use ssh since it's launched with the user's session, that i cannot start... the only thing i could do was getting in guest session (because display jumps, i can quickly press "down" then "left" but there is no way i can enter my password to login). Tried uninstalling the apps that cause problems before upgrading but the boot stucks at network preparation) maybe the new packages provided since your post are not compatible, maybe i need to ask it to login automatically ! the errors i got by simply upgrading refer to gtk and pixbuf, it'll give it a few more tries... :) – Yvain Jun 18 '17 at 10:01
  • well I did a dist-upgrade instead of upgrade and now it's almost fine; display is broken but i have access to ttys (needs otg keyboard) and its not messed up, login screen is ok, no connecting is possible to either user nor guest session (good thing), i don't have to start it all over no more. Just need to fix x or lightdm i'm not sure about how but i'm sure it's manageable. – Yvain Jun 18 '17 at 19:20
6

Step One: Download Everything

First, grab the latest Raring daily build files for the 2012 Nexus 7:

ubuntu-13.04-preinstalled-desktop-armhf+nexus7.bootimg

ubuntu-13.04-preinstalled-desktop-armhf+nexus7.img.gz

(found here: http://old-releases.ubuntu.com/releases/raring/)

Next, grab the tools required to install these build files to your device:

  1. On your computer, press Ctrl+Alt+T to start a terminal.

  2. Add the Ubuntu SDK Release PPA:

    $ sudo add-apt-repository ppa:ubuntu-sdk-team/ppa

  3. Update your system to use the latest packages:

    $ sudo apt-get update

    $ sudo apt-get upgrade

  4. Install the ubuntu-device-flash package:

    $ sudo apt-get install ubuntu-device-flash

(found here: https://developer.ubuntu.com/en/phone/devices/installing-ubuntu-for-devices/)

Step Two: Unlock Your Device

The 2012 Nexus 7 ships with a locked bootloader meaning you must unlock it to flash different images to the device. Fortunately, this is a trivial process, and you only need to do it once.

(Warning: Unlocking the bootloader erases all data and resets the device to factory defaults. If you would rather not lose all of your precious cat pictures, back them up to your computer!)

  1. Reboot your 2012 Nexus 7 into the Android boot loader. To do this, first power down the device in the normal fashion (hold down the power button, then select power off and wait a few seconds). From the off state, hold the volume down button and press the power button. Continue holding the volume down and power buttons until you see the boot loader UI.

  2. Using a micro-USB cable (the one you use for charging should be fine), plug your device into any computer running Ubuntu. The device now displays the boot loader GUI, which looks like this:

This is the bootloader.

  1. Verify fastboot lists the device. In a terminal on Ubuntu, run:

    $ sudo fastboot devices

  2. Start the bootloader unlock process:

    $ sudo fastboot oem unlock

  3. Your device should now prompt you to unlock the bootloader. Follow the on-screen directions to continue. Your screen should now look like this:

This is the prompt.

  1. Complete the process by rebooting:

    $ sudo fastboot reboot-bootloader

When the device reboots back into the bootloader (fastboot mode), you should see "LOCK STATE - UNLOCKED" in small red print. At this point your device is now unlocked.

(from here: https://wiki.ubuntu.com/Nexus7/Installation)

Step Three: Install Everything

  1. Gunzip the *.img.gz file downloaded in Step One to extract the .raw file inside.

  2. Verify once more that your device is connected via micro-USB and that fastboot lists the device by running the following in terminal:

    $ sudo fastboot devices

(If your device is not listed, ensure that the device is turned on and booted to the bootloader.)

  1. Issue the following series of commands:

    $sudo fastboot erase boot

    $sudo fastboot erase userdata

    $sudo fastboot flash boot /path/to/*.bootimg

    $sudo fastboot flash userdata /path/to/unzipped/*.raw

    $sudo fastboot reboot

Step Four: Use Your Device

If everything went right, you should now have Ubuntu Desktop running on your 2012 Nexus 7! The installer will likely be buggy, but very familiar. Beware, of course, that this version of Ubuntu is no longer supported by Canonical, and you may have some difficulty finding and using the latest applications on your device. Good luck, and have fun with your newish oldish Ubuntu tablet!

  • How usable is it? Is it possible to upgrade to a newer version of Ubuntu once Raring is installed? – imolit Sep 21 '16 at 18:13
  • 3
    @imolit It's usable, but I certainly wouldn't recommend it as a daily driver. I primarily use it as a means of monitoring server clusters over ssh while I use my main machine for other things (i.e. something along the lines of a semi-portable second monitor). I attempted to upgrade to 16.04 and ended up corrupting the installation altogether, forcing me to reinstall. However, in his answer, zorbon.cz reports having gotten 14.04 Trusty Tahr to work, but I have yet to try it myself. Good luck, and have fun! :) – Cosmo Sep 22 '16 at 0:18
2

You can use the manual installation instructions from https://wiki.ubuntu.com/Nexus7/Installation - the location of the files is no longer valid, but the files are still available here: http://cdimage.ubuntu.com/releases/raring/release/

The instructions boil down to these commands:

fastboot erase boot
fastboot erase userdata
fastboot flash boot /path/to/*.bootimg
fastboot flash userdata /path/to/*.img

However there seem to be other options for getting a "real" Linux on the Nexus 7 (2012) which are listed here https://github.com/Tasssadar/multirom/wiki/Grouper-Native-Desktop-Linux

Please also note that Nexus 7 (2013), Nexus 4 and Nexus 10 are supported by Ubuntu Touch, see https://developer.ubuntu.com/en/start/ubuntu-for-devices/devices/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.