6

Probably a really common issue I know but I keep getting 'Disconnected - You are now offline' on a fairly regular basis and my connection will cut out for anything between 30 secs to half an hour or something like that. I've really no idea as to why it may be occuring. Any suggestions would be appreciated. I'm running Ubuntu 14.04.

I've seen these files referenced in other similar posts. I've not been able to find the solution so far:

/etc/network/interfaces:
# interfaces(5) file used by ifup(8) and ifdown(8)
auto lo
iface lo inet loopback
/etc/resolv.conf:
# Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
#     DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
nameserver 127.0.1.1
ifconfig:
eth0      Link encap:Ethernet  HWaddr f8:0f:41:eb:56:f2  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:1916 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1916 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:155737 (155.7 KB)  TX bytes:155737 (155.7 KB)

wlan0     Link encap:Ethernet  HWaddr 30:10:b3:fc:55:04  
          inet addr:192.168.0.5  Bcast:192.168.0.255  Mask:255.255.255.0
          inet6 addr: fe80::3210:b3ff:fefc:5504/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:2388 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2355 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:1796538 (1.7 MB)  TX bytes:418490 (418.4 KB)

And the output of lspci -knn | grep Net -A2 is:

01:00.0 Network controller [0280]: Qualcomm Atheros AR9462 Wireless Network Adapter [168c:0034] (rev 01)
    Subsystem: Lite-On Communications Inc Device [11ad:6621]
    Kernel driver in use: ath9k
  • Which network interface is mounted on your computer? You can see it with the command lspci. Maybe there is an issue with your network driver. – Michele Jun 8 '15 at 12:01
  • Please edit your question and add output of lspci -knn | grep Net -A2 terminal command. – Pilot6 Jun 8 '15 at 12:09
  • Does dmesg produce anything useful after this happens? – Stephen Jun 8 '15 at 12:13
  • @Stephen I bet it is another Realtek wireless. He needs just to change driver. – Pilot6 Jun 8 '15 at 12:29
  • The output of lspci contains the following liine towards the bottom so it would appear to be Realtek wireless - 02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 0c). – jonnjo2005 Jun 8 '15 at 13:26
1

Not sure how you can troubleshoot like this. Also I apologize, I am not able to comment. Try to disable the NetworkManager and use wpa_supplicant and dhclient manually. Don't run wpa_supplicant with the -B argument to run in the background, that way you can see what it says when you disconnect. Its going to be something like this

echo `wpa_passphrase ssid passphrase` >> /etc/wpa_supplicant.conf
wpa_supplicant -iinterface -c/etc/wpa_supplicant.conf
dhclient wlan0

Now when you disconnect look at the error it gives you. Also check the lease time when you use dhclient.

  • 1
    Why was this suggestion down-voted? This is a good way to get relevant and useful debugging information. – Stephen Jun 8 '15 at 12:13
  • 1
    Also, you don't need the echo, you can just wpa_passphrase ssid passphrase > whatever-file You don't have to use the absolute path, since the user likely will only have used this for debugging. You should probably have mentioned how to disable NetworkManager, too... – Stephen Jun 8 '15 at 12:37
  • Probably. I'm not used to giving a full complete answer, that way whoever I am answering to will have to do a little research and learn in the process instead of just copying and pasting commands. – Webtm Jun 8 '15 at 12:44
  • Good practice, but a link wouldn't violate that.... – Stephen Jun 8 '15 at 12:49
  • And also if you disable NM, there must be a manual how to enable it back. – Pilot6 Jun 8 '15 at 13:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.