I've just installed a fresh copy of 10.10 and for some reason the mouse wouldn't work correctly.

I can move it, and I even have context menu on the desktop and the network and sound applets (I am using the default theme if that even matters), however I cannot open anything else.

The mouse is a A4TECH X-708 connected via USB and the keyboard is on PS/2.

  • Do you mean that you are able to right click but not left click (doucle click) to open apps etc?
    – Antonis
    Oct 12 '10 at 9:14
  • Yes. There is no problem with the mouse as it works fine under Windows.
    – pmanolov
    Oct 12 '10 at 10:26
  • I've got a similar problem (mouse gets stuck on left click), with a 'Microsoft IntelliMouse Optical 1.1A' mouse (mouse and keyboard are both connected with USB). The mouse works fine in Windows XP/7, Ubuntu 9.04 and 10.04 but not 10.10 (tried with an upgrade from 10.04 and also a fresh install). I've tried different USB ports (front+back), a different mouse and there doesn't seem to be anything relevant in the log files (I've looked in /var/log/syslog, /var/log/dmesg and /var/log/Xorg.0.log). The fresh install consists of just the standard desktop packages and the proprietary nvidia drivers. Oct 12 '10 at 19:55
  • Simple answer here; Having encountered the problem myself, have you plugged in another mouse? Left-button on the mouse is the most heavily used button on most computers, and often the first to wear out. Oct 16 '10 at 0:59
  • I am experiencing the same problem. It only occurs if I touch my keypad while typing. The left button not only stops working on my optical mouse but also the button on the laptop.
    – user10122
    Feb 2 '11 at 22:16

I had the same problem with a Microsoft keyboard when pressing any special keys like the calc button or the volume controls. The left mouse button stop responding. You can find a possible solution in the comment #49 from a bug report: https://bugs.launchpad.net/ubuntu/maverick/+source/linux/+bug/636311

The package is for x64 but I think the x86 version is available too.

It fix my problem. Let me know if it helps you.

  • I'll try this out later. Oct 16 '10 at 6:52
  • 1
    I had the same problem and this packaged fixed it.
    – Juliano
    Oct 16 '10 at 17:12
  • 1
    Worked like a charm :)
    – pmanolov
    Oct 18 '10 at 18:24
  • I think comment #40 fixed it for me (sometimes click did not work, just sometimes). I had duplicates under xinput list even though one did not pass the test. Then I did xinput disable 12. The mouse is "Microsoft Microsoft® Nano Transceiver v1.0".
    – dashesy
    Feb 25 '17 at 5:52

I had exactly the same problem and here's how to solve it. Open terminal and type:

sudo apt-get repository ppa:raof/aubergine
sudo apt-get update
sudo apt-get upgrade

...and when update/upgrade is complete,reboot your system and VOILA! mouse (including left click) works. :)

Another possible solution (I didn't try it out,but it's said to be working) is to download and install .dab files from this location:(since I'm new member,I can only post 1 link)


for x86 version browse,download and install this file


and for x64 version browse,download and install this file:


  • 2
    Do you know why 'sudo apt-get repository ppa:raof/aubergine' helps? Will some Debian files be automoatically installed because one added another repository? And those files fixes some mouse related bug?
    – Varun
    Jan 6 '14 at 4:57

I Have exactly the same problem.

No problems in windows with the mouse, even an other mouse doesn't work. Only the first mouse click works. After that my mouse is dead (except I still can move it)

I first thought it had something to do with gnome, so i downloaded Kubuntu10.10 but there I had the same problem. So it is definitely something with the Xorg server in (k)ubuntu 10.10

I can't find any solution on the net, but I see that there are many others out there who experience the same problem! Please, I remember my earlier Linux experiences much more satisfying than:

"Perhaps if you unplug and then plug the mouse in again it might fix the problem as well."


You are not alone! It's well known critical bug in Maverick 10.10. It even affects my spare laptop with Synaptic touchpad. Wait for updates, or use workaround here: https://bugs.launchpad.net/ubuntu/maverick/+source/linux/+bug/636311


I had this problem in Lubuntu 12.04 as well. What worked for me was to pull up a terminal / run bar and type:

killall openbox && sleep 1 && openbox&

(Actually I switched to awesome but I don't think it matters.)

  • 3
    openbox --replace (or openbox --replace &, if you want) is a faster and more reliable way to accomplish what the above command is usually intended to do. Jun 21 '12 at 0:00

I also had this problem with Ubuntu 10.04. My simple and working solution (with a rough translation from the German-language menus):

Enter the >System >Settings >CompizConfig Manager >Settings >Profile >Reset

This did the job immediately.


I have the same problem on occasion. It happens with the mouse I use on my laptop which I didn't have any problems with in 10.04. The trackpad still works and as soon as I use it the problem with the mouse goes away.

Perhaps if you unplug and then plug the mouse in again it might fix the problem as well.


Had the same problem. Mouse's left button won't respond when I bring up xcalc from the keyboard cal button. Only way to resolve it is to unplug/plug-in the usb mouse.

Current workaround I found is to use usb->ps2 converter. I plug my usb mouse into the usb->ps2 converter, then plug it into ps2 mouse port. After that, problem is gone and I can function as normal.


For what it's worth, I went into the package manager and searched for, 'mouse'. After that, I clicked on all the already installed applications (there aren't that many) and reinstalled all of 'em. Then I searched for 'keyboard' and did the same thing. Not much change there, either. Finally, I searched for 'input' and found a file called, 'inputattach'. Reinstalled it and my mouse problems are solved. Works like it did on the day I installed 10.04. It's so nice to have a mouse that behaves itself and works like it should, again.

I'm a relatively new Ubuntu user, but instead of asking a lot of questions and then waiting for someone to reply and jump through a lot of hoops trying the workarounds and suggestions, I decided to try and do something about it on my own, and managed to solve my mouse problems (computer mouse, that is...;)

What the file 'inputattach' re-installation cleared up, was the need to click several times to open up a folder, having to hold the button down for sometimes as long as three or four seconds before the click would be activated, or having to right click to open a folder or open a file with a particular application.

Just wanted to share this with you since the 'input' of my mouse now seems to once again, be completely and fully 're-attached' to my computer's OS.

Not the answer you're looking for? Browse other questions tagged or ask your own question.