0

I have remote Ubuntu server to which i am connecting through ssh using Cygwin from my local machine Windows 7. I want to create remote desktop connection from my Windows 7 to Ubuntu so i installed XRDP on the server with this command:

sudo apt-get install xrdp

Then i set a password for the default ubuntu user and tried to connect with RDC client from Windows 7. I was able to connect and the screen display was in text mode because i haven't installed a desktop on the ubuntu server.

Then i installed the lightweight desktop LXDE desktop on the server and tried to connect again with RDC but i was unable to. The Windows 7 RDC connects to the server but right after i enter my login name and password the connection breaks down. I am trying to find the reason why.

If i check the status of the xrdp service it shows this:

ubuntu@ip-xx-xx-xx-xx:~$ service xrdp status * Checking status of Remote Desktop Protocol server xrdp [ OK ] * Checking status of RDP Session Manager sesman [fail]

It seems that the session manager is failing to start and i think this might be the reason the connection breaks down. But i don't know what is causing session manager to fail to start.

How to find why the session manager is not starting?

Edit: I was able to create remote desktop connection after i installed xfce desktop envirenment on the server but first i had to create .xsession file in the home directory and add this line in the file xfce4-session. But the connection is not fast and lags. I also installed other desktop envirenments but was unenable to establish connection.

I also tried to install teamviewr and VNC server but that is too much hussle.

It seems that there is no simple solution for lunux machines to create remote desktop connection.

2
  • What do you need rdp for? – davidbaumann Jun 7 '15 at 14:48
  • Because it's more easy to setup. – user1800997 Jun 7 '15 at 15:35
2

xRDP software package support remote desktop connection from Windows machine. The solution is working quite well as long as you define and install an alternate desktop and you tell your linux machine which desktop to use when performing a remote desktop connection

installing and configuring xRDP and have it working is pretty straight forward and simple nowadays. To summarize

  • Step 1 - Install xrdp (sudo apt-get install xrdp)
  • Step 2 - install a desktop. we use mate-desktop (sudo apt-get install mate-core mate-desktop-environment mate-notification-daemon)
  • Step 3 - tell your system to use mate-desktop by issuing the following command

echo mate-session >~/.xsession

Restart and you are done.....

there might be some small additional configuration settings to be done. You can find a detailed and easy to use step by step instructions here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.