2

I'm using the awesome wm and awsetbg to draw the background. Suddenly, for a mysterious reason, it doesn't work (awsetbg /some/file.jpg), and when I try to get it to use a random directory (awsetbg -r /path/to/pics/dir) it says "invalid random wallpaper directory." Why is that, and how can I fix it? The directory doesn't contain anything but image files.

Update: I tried both awsetbg -r ~/Pictures and awsetbg -r /usr/share/backgrounds, but neither work.

2

If you use -r without a wallpaper setter installed awsetbg will set the directory to "#535d6c" which is invalid, install any wallpaper setter to fix it.

sudo apt-get install feh

Instead of feh you can try chbg, xsri, display, Esetroot, wmsetbg, xsetbg, xli, qiv, xv, hsetroot, habak, fvwm-root or icewmbg.

2

Use -R not -r

Worked for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.