0

could somebody explain how to set the unity-greeter select fvwm on ubuntu 14.04?

In 12.04 it was easy, you just installed fvwm and it magically showed up as one of the options on the greeter screen. This doesn't happen in fvwm, you aren't offered a menu of choices for your desktop manager.

When I installed fvwm, it places the following file, called fvwm.desktop, into the directory /usr/share/xsessions.

[Desktop Entry]
Name=Fvwm
Comment=Fvwm
Exec=fvwm2
Terminal=False
TryExec=fvwm2
Type=Application

[Window Manager]
SessionManaged=true

The syntax of this command is slightly different from the default, ubuntu.desktop, which looks like:

[Desktop Entry]
Name=Ubuntu
Comment=This session logs you into Ubuntu
Exec=gnome-session --session=ubuntu
TryExec=unity
Icon=
Type=Application
X-LightDM-DesktopName=Unity
X-Ubuntu-Gettext-Domain=gnome-session-3.0

I've tried a few obviously things, like changing --session=ubuntu to --session=fvwm2, but nothing works. - If I leave ubuntu.desktop in /usr/share/xsesssions, and enter my password, I'm logged into the ubuntu desktop.
- If I remove ubuntu.desktop from the xsessions directory, I get the message:

failed to start session

Thanks very much for any advice!

  • Don't you get the choice when you click on the little Ubuntu symbol above the login names? – ubfan1 Jun 7 '15 at 0:00
1

I just installed after reading your post. I ran an apt-cache search

:~$ apt-cache search fvwm

and selected and installed fvwm-crystal

:~$ sudo apt-get install fvwm-crystal -y

FVWM-crystal

Before installing fvwm-crystal I was using an openbox derivative and removed all of my /usr/share/xsessions/.desktop files, except openbox.desktop that way I would only be presented with the one DE option by the unity-greeter.

After downloading and installing FVWM DE, I clicked on the icon in the top left corner of the input dialogue box, and there was now three options to choose from: Openbox, FVWM, and FVWM-crystal. I chose FVWM-crystal it logged me right in.

Im using TrustyTahr 14.04 with the 3.13.53 kernel version. This is what the

/usr/share/xsessions/fvwm-crystal.desktop

file looks like which is what aloud me to login.

# /usr/share/xsessions/fvwm-crystal.desktop 
[Desktop Entry]
Encoding=UTF-8
Name=FVWM-Crystal
Comment=Umm... Nice desktop. Transparent, and all...
Exec=fvwm-crystal
Terminal=False
#TryExec=fvwm-crystal
Type=Application

[Window Manager]
SessionManaged=true

Trying installing the Desktop Environment (fvwm-crystal) and not just the window manager, if you haven't already done so, and login to the fvwm-crystal option.

  • Thanks very much GeoffW. Followed your instructions to the letter. Everything is the way I wanted it to be now, except I'm using fvwm not fvwm-crystal. My fvwm.desktop looks exactly like yours except for this change: Exec=/usr/bin/fvwm. I now get an icon, with three options, ubuntu, fvwm and fvwm-crystal. – Leo Simon Jun 7 '15 at 4:32
  • I'd like to mark this thread as SOLVED, but as usual, that's the hardest part of the whole process. There's supposed to be a Thread Tools icon, but there isn't – Leo Simon Jun 7 '15 at 5:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.