0

One day, my ASUS PB238Q monitor started having a strong pink tint to it.

Question: How can I tell if this is a software or hardware problem? If it's a software issue, how can I fix it?


Background

It's connected via HDMI.

I tried a couple solutions:

  • I switched HDMI cables
  • I also hooked in a different Ubuntu 14.04 laptop
  • I also tried a DisplayPort -> VGI cable

None of these made a difference.

Here's the output of xrandr:

~ $ xrandr
Screen 0: minimum 320 x 200, current 3280 x 1080, maximum 32767 x 32767
eDP1 connected primary 1360x768+1920+0 (normal left inverted right x axis y axis) 345mm x 194mm
   1920x1080      60.0 +   59.9  
   1680x1050      60.0     59.9  
   1600x1024      60.2  
   1400x1050      60.0  
   1280x1024      60.0  
   1440x900       59.9  
   1280x960       60.0  
   1360x768       59.8*    60.0  
   1152x864       60.0  
   1024x768       60.0  
   800x600        60.3     56.2  
   640x480        59.9  
VGA1 disconnected (normal left inverted right x axis y axis)
DP1 disconnected (normal left inverted right x axis y axis)
HDMI1 disconnected (normal left inverted right x axis y axis)
HDMI2 connected 1920x1080+0+0 (normal left inverted right x axis y axis) 509mm x 286mm
   1920x1080      60.0*+   50.0     59.9  
   1920x1080i     60.1     50.0     60.0  
   1680x1050      59.9  
   1280x1024      75.0     60.0  
   1440x900       59.9  
   1280x960       60.0  
   1152x864       75.0  
   1280x720       60.0     50.0     59.9  
   1440x576       50.0  
   1024x768       75.1     70.1     60.0  
   1440x480       60.0     59.9  
   832x624        74.6  
   800x600        72.2     75.0     60.3     56.2  
   720x576        50.0  
   720x480        60.0     59.9  
   640x480        75.0     66.7     60.0     59.9  
   720x400        70.1  
VIRTUAL1 disconnected (normal left inverted right x axis y axis)

Here are the relevant graphics card details:

~ $ lspci | grep -P "(VGA|NVIDIA)"
00:02.0 VGA compatible controller: Intel Corporation 4th Gen Core Processor Integrated Graphics Controller (rev 06)
01:00.0 3D controller: NVIDIA Corporation GK107M [GeForce GT 750M] (rev a1)

I also tried messing with the colors using:

xrandr --output HDMI2 --prop --verbose --gamma 1.0:5.0:1.0

(which I read about here) but it doesn't seem it'll fix the issue. The white areas still appear neon pink.

Here's a picture (had to use my camera since using a screenshot showed normal colors):

enter image description here

5
  • 1
    Well if you have tried different computers and got the same result, then it's obviously the monitor. Looks like the driver for green has crapped out, leaving you with only red and blue. – psusi Jun 6 '15 at 21:03
  • @psusi, so you're saying it's probably the monitor, but then you say it looks like the driver has an issue... Isn't the driver software? In which case I might be able to find a software solution, right? – Garrett Jun 7 '15 at 0:42
  • 1
    In this case, driver means the electrical line driver in the monitor. – psusi Jun 7 '15 at 0:52
  • @psusi, thanks. So in this situation, is there anything that can be done from my laptop to fix the monitor's electrical line driver? – Garrett Jun 7 '15 at 1:23
  • 2
    No; the monitor is physically busted. – psusi Jun 7 '15 at 13:02
1

Since you said that a screenshot shows normal colors, it is most likely a hardware problem.

I would suggest testing on multiply machines to determine if its

  • your machine's graphic card

  • the cable

    or

  • the monitor

Though, I think it's the cable, try changing it.

3
  • I did try changing the cable and trying on multiple machines... – Garrett Jun 7 '15 at 0:40
  • 1
    Then your monitor or probably the input at your monitor is broken, for sure its not your PC or any software on them... – FatalMerlin Jun 7 '15 at 19:40
  • @Garrett: If this answer helped you, don't forget to click the grey at the left of this text, which means "yes, this answer is valid"! ;-) (I've seen this before and your monitor is just not outputting any green, making it a hardware problem, making it off-topic here on Ask Ubuntu) – Fabby Jun 8 '15 at 13:34

Not the answer you're looking for? Browse other questions tagged or ask your own question.