0

I am having a problem reading files from an exFAT formatted XQD card. The card was formatted by a Sony fs7 camera and contains 4k video files shot using the fs7. The card is a lexar 64gb and the card reader is a lexar professional workflow XR1 USB 3 card reader.

I mounted the card using the following sudo mount -t exfat /dev/sdk1 ~/mountlocation

I have installed exfat-utils and fuse-exfat (I first tried exfat-fuse but had the same results) and have mounted the drive (sdk in this case) to a folder. The drive contains a folder XDROOT, in this folder are several files and folders.

Clip  CUEUP.XML  DISCMETA.XML  Edit  General  MEDIAPRO.XML  Sub  Take  Thmbnl  UserData

When I run sudo ls * I get the following output

CUEUP.XML  DISCMETA.XML  MEDIAPRO.XML

Clip:
ls: reading directory Clip: Input/output error

Edit:

General:
Sony

Sub:

Take:
REDACTED-0008U01M01.XML  REDACTED-0008U01.SMI

Thmbnl:

UserData:

The problem is the IO error when reading the contents of the Clip folder, as this is where all of the video files are. Does anyone have any ideas on how to solve this?

I have tested the XQD card on a windows 7 machine with the same card reader and it worked fine. I also ran

sudo badblocks -sv /dev/sdk

Which came back fine.

EDIT: The version of Ubuntu is 12.04 x64 server with 32gb of RAM and a quad core. In the Clip folder are two 28gb mxf video files. The contents of Clip appear fine under Windows. I tested this on another ubuntu machine (14.04 x64 desktop) and the the Clip folder was empty in the GUI folder browser but when ls * was run from the terminal I get the same IO error. Is there some sort of large file size limitation that I am not aware of?

  • Just thought it might be worth mentioning that there are 2 28gb mxf video files in the Clip folder – eliongater Jun 6 '15 at 2:42
1

Appears to be a problem with how the camera formats the XQD card. If I format the XQD card as exFAT on windows and then copy the exact same files onto it, it works. So it must be how either camera is formatting the card or how the camera is writing to the card.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.