8

After install Ubuntu 14.04 LTS ... everything works fine withouth doing update ... after few minutes my wifi drops wireless conn .. I must to reboot for using it again.

My Network controller:

Realtek Semiconductor Co., Ltd. RTL8723BE PCIe Wireless Network Adapter
Kernel driver in use: rtl8723be

I used the following script http://ubuntuforums.org/showthread.php?t=370108

########## wireless info START ##########

Report from: 06 Jun 2015 12:41 CDT -0500

Booted last: 06 Jun 2015 12:08 CDT -0500

Script from: 21 May 2015 09:10 UTC +0000

##### release ###########################

Distributor ID: Ubuntu
Description:    Ubuntu 14.04.2 LTS
Release:    14.04
Codename:   trusty

##### kernel ############################

Linux 3.16.0-30-generic #40~14.04.1-Ubuntu SMP Thu Jan 15 17:43:14 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

Parameters: ro, quiet, splash, vt.handoff=7

##### desktop ###########################

Ubuntu

##### lspci #############################

08:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8723BE PCIe Wireless Network Adapter [10ec:b723]
    Subsystem: Lenovo Device [17aa:b736]
    Kernel driver in use: rtl8723be

09:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 10)
    Subsystem: Lenovo Device [17aa:380d]
    Kernel driver in use: r8169

##### lsusb #############################

Bus 002 Device 002: ID 8087:8000 Intel Corp. 
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 8087:8008 Intel Corp. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 004: ID 045e:0782 Microsoft Corp. 
Bus 003 Device 003: ID 0bda:b728 Realtek Semiconductor Corp. 
Bus 003 Device 002: ID 174f:14b8 Syntek 
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

##### PCMCIA card info ##################

##### rfkill ############################

0: ideapad_wlan: Wireless LAN
    Soft blocked: no
    Hard blocked: no
1: hci0: Bluetooth
    Soft blocked: yes
    Hard blocked: no
2: ideapad_bluetooth: Bluetooth
    Soft blocked: yes
    Hard blocked: no
3: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no

##### lsmod #############################

rtl8723be              85054  0 
btcoexist              50304  1 rtl8723be
rtl8723_common         23361  1 rtl8723be
rtl_pci                26690  1 rtl8723be
rtlwifi                64255  2 rtl_pci,rtl8723be
mac80211              652718  3 rtl_pci,rtlwifi,rtl8723be
mxm_wmi                13021  1 nouveau
cfg80211              494330  2 mac80211,rtlwifi
ideapad_laptop         18278  0 
sparse_keymap          13948  1 ideapad_laptop
wmi                    19193  2 mxm_wmi,nouveau

##### interfaces ########################

auto lo
iface lo inet loopback

##### ifconfig ##########################

eth0      Link encap:Ethernet  HWaddr <MAC 'eth0' [IF]>  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

vmnet1    Link encap:Ethernet  HWaddr <MAC 'vmnet1' [IF]>  
          inet addr:172.16.229.1  Bcast:172.16.229.255  Mask:255.255.255.0
          inet6 addr: fe80::250:56ff:fec0:1/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:59 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

vmnet8    Link encap:Ethernet  HWaddr <MAC 'vmnet8' [IF]>  
          inet addr:192.168.42.1  Bcast:192.168.42.255  Mask:255.255.255.0
          inet6 addr: fe80::250:56ff:fec0:8/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:59 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

wlan0     Link encap:Ethernet  HWaddr <MAC 'wlan0' [IF]>  
          inet addr:192.168.1.72  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::2e33:7aff:fe18:82d5/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:25404 errors:0 dropped:0 overruns:0 frame:0
          TX packets:20720 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:19104265 (19.1 MB)  TX bytes:3957097 (3.9 MB)

##### iwconfig ##########################

eth0      no wireless extensions.

vmnet1    no wireless extensions.

vmnet8    no wireless extensions.

lo        no wireless extensions.

wlan0     IEEE 802.11bgn  ESSID:"ManzanaVILot176"  
          Mode:Managed  Frequency:2.462 GHz  Access Point: <MAC 'ManzanaVILot176' [AC1]>   
          Bit Rate=18 Mb/s   Tx-Power=20 dBm   
          Retry short limit:7   RTS thr=2347 B   Fragment thr:off
          Power Management:off
          Link Quality=46/70  Signal level=-64 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:57   Missed beacon:0

##### route #############################

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         192.168.1.254   0.0.0.0         UG    0      0        0 wlan0
172.16.229.0    0.0.0.0         255.255.255.0   U     0      0        0 vmnet1
192.168.1.0     0.0.0.0         255.255.255.0   U     9      0        0 wlan0
192.168.42.0    0.0.0.0         255.255.255.0   U     0      0        0 vmnet8

##### resolv.conf #######################

nameserver 127.0.1.1
search gateway.2wire.net

##### network managers ##################

Installed:

    NetworkManager

Running:

root       931     1  0 12:08 ?        00:00:00 NetworkManager

##### NetworkManager info ###############

NetworkManager Tool

State: connected (global)

- Device: eth0 -----------------------------------------------------------------
  Type:              Wired
  Driver:            r8169
  State:             unavailable
  Default:           no
  HW Address:        <MAC 'eth0' [IF]>

  Capabilities:
    Carrier Detect:  yes

  Wired Properties
    Carrier:         off

- Device: wlan0  [ManzanaVILot176] ---------------------------------------------
  Type:              802.11 WiFi
  Driver:            rtl8723be
  State:             connected
  Default:           yes
  HW Address:        <MAC 'wlan0' [IF]>

  Capabilities:
    Speed:           18 Mb/s

  Wireless Properties
    WEP Encryption:  yes
    WPA Encryption:  yes
    WPA2 Encryption: yes

  Wireless Access Points (* = current AP)
    INFINITUMc7qc:   Infra, <MAC 'INFINITUMc7qc' [AN1]>, Freq 2412 MHz, Rate 54 Mb/s, Strength 100 WPA WPA2
    Zandunga:        Infra, <MAC 'Zandunga' [AN2]>, Freq 2437 MHz, Rate 54 Mb/s, Strength 100 WPA2
    *ManzanaVILot176:Infra, <MAC 'ManzanaVILot176' [AC1]>, Freq 2462 MHz, Rate 54 Mb/s, Strength 82 WPA
    Motorola:        Infra, <MAC 'Motorola' [AN4]>, Freq 2412 MHz, Rate 54 Mb/s, Strength 100 WPA2

  IPv4 Settings:
    Address:         192.168.1.72
    Prefix:          24 (255.255.255.0)
    Gateway:         192.168.1.254

    DNS:             192.168.1.254

##### NetworkManager.state ##############

[main]
NetworkingEnabled=true
WirelessEnabled=true
WWANEnabled=true
WimaxEnabled=true

##### NetworkManager.conf ###############

[main]
plugins=ifupdown,keyfile,ofono
dns=dnsmasq

[ifupdown]
managed=false

##### NetworkManager profiles ###########

[[/etc/NetworkManager/system-connections/PEMEX MOVIL]] (600 root)
[ipv6] method=auto
[connection] id=PEMEX MOVIL | type=802-11-wireless
[802-11-wireless] ssid=PEMEX MOVIL | mac-address=<MAC 'wlan0' [IF]>
[ipv4] method=auto

[[/etc/NetworkManager/system-connections/ManzanaVILot176]] (600 root)
[connection] id=ManzanaVILot176 | type=802-11-wireless
[802-11-wireless] ssid=ManzanaVILot176 | mac-address=<MAC 'wlan0' [IF]>
[ipv4] method=auto
[ipv6] method=auto

##### iw reg get ########################

Region: America/Mexico_City (based on set time zone)

country US:
    (2402 - 2472 @ 40), (3, 27)
    (5170 - 5250 @ 40), (3, 17)
    (5250 - 5330 @ 40), (3, 20), DFS
    (5490 - 5600 @ 40), (3, 20), DFS
    (5650 - 5710 @ 40), (3, 20), DFS
    (5735 - 5835 @ 40), (3, 30)
    (57240 - 63720 @ 2160), (N/A, 40)

##### iwlist channels ###################

eth0      no frequency information.

vmnet1    no frequency information.

vmnet8    no frequency information.

lo        no frequency information.

wlan0     11 channels in total; available frequencies :
          Channel 01 : 2.412 GHz
          Channel 02 : 2.417 GHz
          Channel 03 : 2.422 GHz
          Channel 04 : 2.427 GHz
          Channel 05 : 2.432 GHz
          Channel 06 : 2.437 GHz
          Channel 07 : 2.442 GHz
          Channel 08 : 2.447 GHz
          Channel 09 : 2.452 GHz
          Channel 10 : 2.457 GHz
          Channel 11 : 2.462 GHz
          Current Frequency:2.462 GHz (Channel 11)

##### iwlist scan #######################

eth0      Interface doesn't support scanning.

vmnet1    Interface doesn't support scanning.

vmnet8    Interface doesn't support scanning.

lo        Interface doesn't support scanning.

Channel occupancy:

      1   APs on   Frequency:2.462 GHz (Channel 11)

wlan0     Scan completed :
          Cell 01 - Address: <MAC 'ManzanaVILot176' [AC1]>
                    Channel:11
                    Frequency:2.462 GHz (Channel 11)
                    Quality=70/70  Signal level=-32 dBm  
                    Encryption key:on
                    ESSID:"ManzanaVILot176"
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 6 Mb/s; 9 Mb/s
                              11 Mb/s; 12 Mb/s; 18 Mb/s
                    Bit Rates:24 Mb/s; 36 Mb/s; 48 Mb/s; 54 Mb/s
                    Mode:Master
                    Extra:tsf=0000001795c479af
                    Extra: Last beacon: 0ms ago
                    IE: WPA Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (1) : TKIP
                        Authentication Suites (1) : PSK

##### module infos ######################

[rtl8723be]
filename:       /lib/modules/3.16.0-30-generic/kernel/drivers/net/wireless/rtlwifi/rtl8723be/rtl8723be.ko
firmware:       rtlwifi/rtl8723befw.bin
description:    Realtek 8723BE 802.11n PCI wireless
license:        GPL
author:         Realtek WlanFAE <wlanfae@realtek.com>
author:         PageHe  <page_he@realsil.com.cn>
srcversion:     C94095C986767A931B924EF
depends:        rtlwifi,rtl8723-common,rtl_pci,btcoexist,mac80211
intree:         Y
vermagic:       3.16.0-30-generic SMP mod_unload modversions 
signer:         Magrathea: Glacier signing key
sig_key:        7B:E2:A7:20:0F:17:F0:0C:A0:11:F7:0E:5A:87:4C:37:E3:E0:F6:BE
sig_hashalgo:   sha512
parm:           swlps:bool
parm:           swenc:using hardware crypto (default 0 [hardware])
 (bool)
parm:           ips:using no link power save (default 1 is open)
 (bool)
parm:           fwlps:using linked fw control power save (default 1 is open)
 (bool)
parm:           msi:Set to 1 to use MSI interrupts mode (default 0)
 (bool)
parm:           debug:Set debug level (0-5) (default 0) (int)

[rtl8723_common]
filename:       /lib/modules/3.16.0-30-generic/kernel/drivers/net/wireless/rtlwifi/rtl8723com/rtl8723-common.ko
description:    Realtek RTL8723AE/RTL8723BE 802.11n PCI wireless common routines
license:        GPL
author:         Larry Finger    <Larry.Finger@lwfinger.net>
author:         Realtek WlanFAE <wlanfae@realtek.com>
srcversion:     7410431A59C24B1BC33226E
depends:        
intree:         Y
vermagic:       3.16.0-30-generic SMP mod_unload modversions 
signer:         Magrathea: Glacier signing key
sig_key:        7B:E2:A7:20:0F:17:F0:0C:A0:11:F7:0E:5A:87:4C:37:E3:E0:F6:BE
sig_hashalgo:   sha512

[rtl_pci]
filename:       /lib/modules/3.16.0-30-generic/kernel/drivers/net/wireless/rtlwifi/rtl_pci.ko
description:    PCI basic driver for rtlwifi
license:        GPL
author:         Larry Finger    <Larry.FInger@lwfinger.net>
author:         Realtek WlanFAE <wlanfae@realtek.com>
author:         lizhaoming  <chaoming_li@realsil.com.cn>
srcversion:     3273ECD6028617EFD27E4F4
depends:        mac80211,rtlwifi
intree:         Y
vermagic:       3.16.0-30-generic SMP mod_unload modversions 
signer:         Magrathea: Glacier signing key
sig_key:        7B:E2:A7:20:0F:17:F0:0C:A0:11:F7:0E:5A:87:4C:37:E3:E0:F6:BE
sig_hashalgo:   sha512

[rtlwifi]
filename:       /lib/modules/3.16.0-30-generic/kernel/drivers/net/wireless/rtlwifi/rtlwifi.ko
description:    Realtek 802.11n PCI wireless core
license:        GPL
author:         Larry Finger    <Larry.FInger@lwfinger.net>
author:         Realtek WlanFAE <wlanfae@realtek.com>
author:         lizhaoming  <chaoming_li@realsil.com.cn>
srcversion:     8362106E96F806A9DBAE565
depends:        mac80211,cfg80211
intree:         Y
vermagic:       3.16.0-30-generic SMP mod_unload modversions 
signer:         Magrathea: Glacier signing key
sig_key:        7B:E2:A7:20:0F:17:F0:0C:A0:11:F7:0E:5A:87:4C:37:E3:E0:F6:BE
sig_hashalgo:   sha512

[mac80211]
filename:       /lib/modules/3.16.0-30-generic/kernel/net/mac80211/mac80211.ko
license:        GPL
description:    IEEE 802.11 subsystem
srcversion:     D421794D4F30DF3A540FD24
depends:        cfg80211
intree:         Y
vermagic:       3.16.0-30-generic SMP mod_unload modversions 
signer:         Magrathea: Glacier signing key
sig_key:        7B:E2:A7:20:0F:17:F0:0C:A0:11:F7:0E:5A:87:4C:37:E3:E0:F6:BE
sig_hashalgo:   sha512
parm:           max_nullfunc_tries:Maximum nullfunc tx tries before disconnecting (reason 4). (int)
parm:           max_probe_tries:Maximum probe tries before disconnecting (reason 4). (int)
parm:           beacon_loss_count:Number of beacon intervals before we decide beacon was lost. (int)
parm:           probe_wait_ms:Maximum time(ms) to wait for probe response before disconnecting (reason 4). (int)
parm:           ieee80211_default_rc_algo:Default rate control algorithm for mac80211 to use (charp)

[cfg80211]
filename:       /lib/modules/3.16.0-30-generic/kernel/net/wireless/cfg80211.ko
description:    wireless configuration support
license:        GPL
author:         Johannes Berg
srcversion:     DEE8EAA48495E392CD51C2D
depends:        
intree:         Y
vermagic:       3.16.0-30-generic SMP mod_unload modversions 
signer:         Magrathea: Glacier signing key
sig_key:        7B:E2:A7:20:0F:17:F0:0C:A0:11:F7:0E:5A:87:4C:37:E3:E0:F6:BE
sig_hashalgo:   sha512
parm:           ieee80211_regdom:IEEE 802.11 regulatory domain code (charp)
parm:           cfg80211_disable_40mhz_24ghz:Disable 40MHz support in the 2.4GHz band (bool)

##### module parameters #################

[rtl8723be]
debug: 0
fwlps: Y
ips: Y
msi: N
swenc: N
swlps: N

[mac80211]
beacon_loss_count: 7
ieee80211_default_rc_algo: minstrel_ht
max_nullfunc_tries: 2
max_probe_tries: 5
probe_wait_ms: 500

[cfg80211]
cfg80211_disable_40mhz_24ghz: N
ieee80211_regdom: 00

##### /etc/modules ######################

lp
rtc

##### modprobe options ##################

[/etc/modprobe.d/blacklist-ath_pci.conf]
blacklist ath_pci

[/etc/modprobe.d/blacklist.conf]
blacklist evbug
blacklist usbmouse
blacklist usbkbd
blacklist eepro100
blacklist de4x5
blacklist eth1394
blacklist snd_intel8x0m
blacklist snd_aw2
blacklist i2c_i801
blacklist prism54
blacklist bcm43xx
blacklist garmin_gps
blacklist asus_acpi
blacklist snd_pcsp
blacklist pcspkr
blacklist amd76x_edac

[/etc/modprobe.d/blacklist-rare-network.conf]
alias net-pf-3 off
alias net-pf-6 off
alias net-pf-9 off
alias net-pf-11 off
alias net-pf-12 off
alias net-pf-19 off
alias net-pf-21 off
alias net-pf-36 off

[/etc/modprobe.d/iwlwifi.conf]
remove iwlwifi \
(/sbin/lsmod | grep -o -e ^iwlmvm -e ^iwldvm -e ^iwlwifi | xargs /sbin/rmmod) \
&& /sbin/modprobe -r mac80211

[/etc/modprobe.d/mlx4.conf]
softdep mlx4_core post: mlx4_en

[/etc/modprobe.d/modesetting.conf]
options cirrus modeset=1
options mgag200 modeset=1

[/etc/modprobe.d/vmware-fuse.conf]
alias char-major-10-229 fuse

##### rc.local ##########################

exit 0

##### pm-utils ##########################

##### udev rules ########################

[/etc/udev/rules.d/70-persistent-net.rules]
# PCI device 0x10ec:0x8168 (r8169)
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="<MAC 'eth0' [IF]>", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="eth*", NAME="eth0"
# PCI device 0x10ec:0xb723 (rtl8723be)
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="<MAC 'wlan0' [IF]>", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="wlan*", NAME="wlan0"

##### dmesg #############################

[   14.797584] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[   17.537314] wlan0: authenticate with <MAC 'ManzanaVILot176' [AC1]>
[   17.557419] wlan0: send auth to <MAC 'ManzanaVILot176' [AC1]> (try 1/3)
[   17.559066] wlan0: authenticated
[   17.559222] rtl8723be 0000:08:00.0 wlan0: disabling HT/VHT due to WEP/TKIP use
[   17.559226] rtl8723be 0000:08:00.0 wlan0: disabling HT as WMM/QoS is not supported by the AP
[   17.559228] rtl8723be 0000:08:00.0 wlan0: disabling VHT as WMM/QoS is not supported by the AP
[   17.561054] wlan0: associate with <MAC 'ManzanaVILot176' [AC1]> (try 1/3)
[   17.565123] wlan0: RX AssocResp from <MAC 'ManzanaVILot176' [AC1]> (capab=0x431 status=0 aid=2)
[   17.565270] wlan0: associated
[   17.565277] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[   17.630615] bridge-wlan0: device is wireless, enabling SMAC
[   17.630617] bridge-wlan0: up
[   17.630619] bridge-wlan0: attached
[   17.630912] wlan0: deauthenticating from <MAC 'ManzanaVILot176' [AC1]> by local choice (Reason: 2=PREV_AUTH_NOT_VALID)
[   17.663519] wlan0: authenticate with <MAC 'ManzanaVILot176' [AC1]>
[   17.673669] wlan0: send auth to <MAC 'ManzanaVILot176' [AC1]> (try 1/3)
[   17.673891] bridge-wlan0: disabling the bridge
[   17.675828] wlan0: authenticated
[   17.675922] rtl8723be 0000:08:00.0 wlan0: disabling HT/VHT due to WEP/TKIP use
[   17.675924] rtl8723be 0000:08:00.0 wlan0: disabling HT as WMM/QoS is not supported by the AP
[   17.675926] rtl8723be 0000:08:00.0 wlan0: disabling VHT as WMM/QoS is not supported by the AP
[   17.677178] wlan0: associate with <MAC 'ManzanaVILot176' [AC1]> (try 1/3)
[   17.679555] wlan0: RX AssocResp from <MAC 'ManzanaVILot176' [AC1]> (capab=0x431 status=0 aid=2)
[   17.679703] wlan0: associated
[   17.689281] bridge-wlan0: down
[   17.689287] bridge-wlan0: detached
[   17.755541] bridge-wlan0: device is wireless, enabling SMAC
[   17.755543] bridge-wlan0: up
[   17.755546] bridge-wlan0: attached

########## wireless info END ############
  • 1
    No one can help you if that's all the detail you give. PC maker, model, wifi card maker? One shot: bad router config, try assigning a static IP to your machine from said router config. – Christian Jun 5 '15 at 17:29
  • Please edit your question and add output if lspci -knn | grep Net -A2 terminal command. – Pilot6 Jun 6 '15 at 7:43
  • FYI, here is a bug report for it: bugs.launchpad.net/ubuntu/+source/linux/+bug/1461174 – P.-H. Lin Jun 12 '15 at 3:57
  • Did you find any answer to the above problem. I am facing the similar issue. My laptop has also got the same rtl8723be . – Arihant Godha Apr 1 '16 at 7:25
  • You can try my method but only applicable for rtl8723be drivers. Click here for the solution. Hope it helped you :) – user565770 Jul 7 '16 at 16:24
9

After lots of Googling, I found a recent post with new firmware.

  1. Download rtl8723befw.bin, copy it to /lib/firmware/rtlwifi/ and then reboot your laptop.
  2. Disable the sleep feature of the driver:

    $ echo "options rtl8723be fwlps=0" | sudo tee /etc/modprobe.d/rtl8723be.conf

    (I also found information using options rtl8723be fwlps=N ips=N, which disables the ips option, but I did not find it necessary to use this)

I also read in many posts that bluetooth can disrupt the WiFi connection, so I permanently disabled it also: $ sudo rfkill block bluetooth $ sudo update-rc.d bluetooth disable (and check it's turned off with sudo service bluetooth status)

[If you find you are still having problems with WiFi suddenly breaking, you can reload the relevant module with sudo rmmod rtl8723be && sudo modprobe rtl8723be, instead of having to reboot your whole system]

  • 1
    Having used my laptop for the majority of today, I have had no WiFi failures requiring a reboot or reloading of the module. I did have one or two periods where my WiFi was not particularly fast, but it looks as though they have found the issue and are working on it – andyandy Sep 13 '15 at 22:53
3

Having spent a lot of time on multiple forums when I hit this issue on Lenovo G40 and HP Notebook 15-ac122tu, I found this was a pretty common problem with WiFi not working or stoped working intermittently on Ubuntu 14.04.

To me, following three links were relevant:

1) How do I get a Realtek RTL8723BE wireless card to work?

2) Wifi problems with rtl8723be in Ubuntu 14.04

3) My Wifi drops the connection after a few minutes realtek8723be (this post)

What worked for me is a mix of these three posts and some troubleshooting.

I think, a permanent fix in Ubuntu mainline packages with respect to Broadcom or Realtek WiFi adapters will help users. This will go a long way to make Ubuntu more user friendly. Remember, there was time when audio and graphics issues were pretty common, recently it is the same with wireless adapters.

protected by Community Aug 17 '16 at 20:37

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.