I've been having a issue trying to get the adb devices command to pick up my LG TRANSPYRE™ (VS810PP) phone. Keep in mind the command does in fact work. So it's not an issue with adb, more with the drivers.

After taking a look from this post I found online, I did the steps properly (three times, just to be sure).

So I basically did this:

  1. Created a file: /etc/udev/rules.d/70-android.rules.
  2. Wrote SUBSYSTEM=="usb", ATTR{idVendor}=="1004", MODE="0666" to the file.
  3. Assigned proper permissions via sudo chmod a+rx /etc/udev/rules.d/70-android.rules
  4. Rebooted my computer.
  5. Restarted udev.

And the results:

$ adb devices
* daemon not running. starting it now on port 5037 *
* daemon started successfully *
List of devices attached 

(But nothing came after that)

But I didn't give up just yet. I read from another post here on Ask Ubuntu, I tried again.

Again, the process:

  1. Created a file: /etc/udev/rules.d/51-android.rules
  2. Wrote SUBSYSTEMS=="usb", ATTR{idProduct}=="1004", MODE="0666" to the file
  3. Gave proper permissions sudo chmod a+rx /etc/udev/rules.d/51-android.rules
  4. Rebooted the 'pooter.
  5. Restarted udev.

The output is the same as above, still not fixed...

I've very new to android, but my best guess is that I'm using some sort of out-dated method, because those posts are at either 2 or more years old. So there is probably a new method now.

Edit:

$ lsusb
...
Bus 005 Device 005: ID 1004:628a LG Electronics, Inc. 
...

$ dmesg | grep "LG"
[   69.824457] usb 5-1.4: Manufacturer: LG Electronics Inc.
[   73.155776] usb 5-1.4: Product: LGE Android Phone
[   73.155783] usb 5-1.4: Manufacturer: LG Electronics Inc.
[   74.232275] scsi 5:0:0:0: CD-ROM            LGE      Android Platform 0000 PQ: 0 ANSI: 2
[   78.191262] usb 5-1.4: Product: LGE Android Phone
[   78.191268] usb 5-1.4: Manufacturer: LG Electronics Inc.

$ echo "0x1004" > ~/.android/adb_usb.ini
$ adb kill-server
$ adb start-server
* daemon not running. starting it now on port 5037 *
* daemon started successfully *
$ adb devices
List of devices attached 

closed as off-topic by Panther, Tim, user364819, karel, Eric Carvalho Jun 6 '15 at 0:33

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This is not about Ubuntu. Questions about other Linux distributions can be asked on Unix & Linux, those about Windows on Super User, those about Apple products on Ask Different and generic programming questions on Stack Overflow." – Panther, Tim, Community, karel, Eric Carvalho
If this question can be reworded to fit the rules in the help center, please edit the question.

  • Do you have USB debugging enabled on your phone? – s3lph Jun 5 '15 at 13:56
  • @the_Seppi Yes. – user288187 Jun 5 '15 at 13:57
  • Mint isn't supported here. This is on topic on Unix & Linux – Tim Jun 5 '15 at 14:03
  • Are any devices detected by the kernel when plugging the phone? Check the output of dmesg. Please note that Mint is off-topic here. You may want to ask on unix.stackexchange.com or rephrase your question so it fits for Ubuntu (but please check first whether this appears in an official Ubuntu system, an Ubuntu live system on USB should fit that.) – s3lph Jun 5 '15 at 14:03
  • @the_Seppi, when doing lsusb, I get Bus 005 Device 005: ID 1004:628a LG Electronics, Inc. as one of the entries. – user288187 Jun 5 '15 at 14:09
up vote 25 down vote accepted

Set mode from MTP to PTP. I had the same problem.

  • Perhaps this is a problem in themselves LG phones – OlegWock Jun 5 '15 at 14:44
  • Thanks! I've been struggling for quite some time until I found this answer – Warrior Jun 29 '16 at 18:11
  • 4
    additionally do this : Go to Settings -> About phone -> Tap on "Build number" seven times. Voila !!! this enables Developer mode ... You will see new option called 'Developer Options' in the setting. From there I also had to enable USB debugging. Developer Options > USB Debugging ... adb kill-server ... adb start-server – Scott Stensland Aug 12 '16 at 13:45
  • 1
    What does this mean "set mode from MTP to PTP"? – Yanick Rochon Nov 18 '16 at 20:48
  • I had to allow adb and USB debugging explicitly on CM13. See comment from Scott Stensland how to enable – syss Nov 19 '16 at 13:30

This happens to me sometimes with certain devices.

Here's what I find works:

Step 1: Find the Vendor ID

You can do this by typing lsusb. My output is something like this:

Bus 002 Device 097: ID abc1:1234 Fictional Company, Ltd. 

In this case, abc1 is the Vendor ID.

Step 2: Create an adb_usb.ini file

Run the following

echo "0x<your device's Vendor ID>" > ~/.android/adb_usb.ini

Step 3: Restart adb

adb kill-server
adb start-server

Since doing that, my devices have all shown up in adb devices.

  • 2
    It didn't appear to work. Check the edit on the main post I did. – user288187 Jun 5 '15 at 14:24
  • 1
    That's too bad :( I have no other ideas at this point, the adb_usb.ini file works for me – Abe Fehr Jun 5 '15 at 14:34
  • 3
    I'm glad you got this answer in there before the off-topic police arrived. Solved my problem. – mmccoo Aug 5 '16 at 7:27
  • Thanks, that worked for me. I had issue, that occasionally Ubuntu wouldn't find my connected Android device. Now it found it after adb restart. – ViliusK Dec 13 '16 at 14:37
  • Great answer, allowed my adb to see my OnePlus 2 – spectras Dec 17 '16 at 11:14