I'm a Ubuntu noobie - but I got my laptop dual-booted with XP and Ubuntu 11.04, with all updates installed.

I have a Dell Inspiron 5160 with an XGI Volari XP5 video card. It supports 640x480 - 32/16/8 bit color, 800x600 - 32/16/8 bit color, and 1024x768 - 32/16/8 bit color.

I'm pretty sure this is an unsupported chipset for Linux. But, the low-graphics mode works fine when I boot in recovery mode.

How can I set this as my standard video configuration?


You could try adding one or more grub boot options such as "nomodeset" and "xforcevesa" - see my linked answer for help on how to do this.

You can try to use one of the following combinations:



nomodeset xforcevesa

If you boot into recovery-mode you could create a file call xorg.conf:

sudo nano /etc/X11/xorg.conf

copy and paste the following information:

Section "Device"
    Identifier  "Configured Video Device"
    Driver      "fbdev"

Section "Monitor"
    Identifier  "Configured Monitor"

Section "Screen"
    Identifier  "Default Screen"
    Monitor     "Configured Monitor"
    Device      "Configured Video Device"

This is the very basic framebuffer driver that fail safe uses.

Possibly if you change the text Driver "fbdev" to Driver "vesa" this should give you slightly better VESA type graphics.

This wiki page refers to the "trident" video driver. Since your card is a trident you may possibly be able to change the driver to "trident".

This wiki page refers to the "SiS" video driver which contains the "XGI Volari" name of your graphics card - possibly your card is this type in disguise and you may be able to change the driver to "SiS"

Linked Question:

  1. How do I set 'nomodeset' after I've already installed Ubuntu?
  • Fossfreedom, I tried all the combos (xforcevesa, nomodeset, xforcevesa nomodeset) and they all gave the same blank screen. Any other ideas? – JohnM Sep 27 '11 at 17:19
  • VGA compatible controller: Trident Microsystems XGI Volari XP5 (rev 02). Free -m shows 495 MB Mem and 255 MB Swap. – JohnM Sep 27 '11 at 18:47
  • I'm planning on running exactly one thing: Dummynet, so I'm hoping it will be sufficient. – JohnM Sep 27 '11 at 18:48
  • Thanks fossfreedom. The "stock" xorg.conf you gave boots me into a CLI mode "Ubuntu 11.04 ubuntu tty1" then "ubuntu login:". The Gnome gui is gone (I've removed Unity due to hardware limitations). I'll try the driver variations. – JohnM Sep 27 '11 at 21:04
  • 1
    When booting from failsafe mode you'll see a file called /etc/X11/xorg.failsafe - have a look at it - if it is different from what you have tried, try sudo cp /etc/X11/xorg.failsafe /etc/X11/xorg.conf and rebooting. – fossfreedom Sep 27 '11 at 21:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.