Do anybody got success using IP Messenger in ubuntu 14.04 LTS ?

I'm getting error while launching ip-messenger.

Can not setup lock file:/tmp/g2ipmsg.lock errno : -11 (Resource temporarily unavailable)

Well, I can see g2ipmsg process using ps command:

ravi@dell:~$ ps -e | grep "ipmsg"
9266 ? 00:02:33 g2ipmsg

That means, after process is running its just not showing in notification area, and so If i try to re-launch Ip Messenger from dock, its showing error because .lock file is already created at /tmp/g2ipmsg.lock by previous process and its being used.

I've tried many solutions from other questions I've mentioned, but none of them worked for IP Messenger yet.

I know, there something to do with gnome notification panel for allowing ip-messenger icon to appear behind system clock. I did something for skype in past and its working now. May be I need to do same for ip-messenger too but don't remember what solution I used for skype.

Any help would be appreciated.

Thank you!

2 Answers 2


After spending lot of efforts, I've found two solutions:

1. Wine

Install wine to run IPMsg.exe on ubuntu. But it has a problem while transferring files. Ubuntu system can only receive files form IPMsg if its running using wine. While sending files from Ubuntu to Windows based IPMsg it will show 0KB file size and it will not allow you to receive any files.

So if you are just looking for non-file transfer solution. Just install wine and run IPMsg.exe.

2. iptux (Preffered solution)

This is the solution I've used finally. Installed iptux in my ubuntu system and its all working now. I can send files to windows users who are using IPMsg.exe.

$ sudo apt-get install iptux
  • Sending file from IPMsg (Windows system) to iptux(Ubuntu system)

Sending file from IPMsg (Windows system) to iptux(Ubuntu system)

  • Receiving file at iptux (Ubuntu system)

 Receiving file at iptux (Ubuntu system)

Update: Sometimes iptux also unable to send file from Linux system to any other. In such case please try transferring directory instead files. It works.

  • 3
    After lots of trying I could not share file using iptux but your advice of transfereing dirs worked well. Thanks for advice.
    – silverwolf
    Nov 17, 2015 at 4:14
  • @silverwolf Glad, it helped you! :) Nov 17, 2015 at 16:23

I have another alternative: PetaClone

It uses Java so you may need to install Java Runtime Environment.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .