0

I had a similar problem as this person. Namely, I tried to install a Realtek audio driver and my laptop could no longer find my audio card. I followed the solution given in the post I linked, but no luck. I've also uninstalled and reinstalled the ALSA mixer, but no luck there either.

The full alsa report is here.

Based on the troubleshooting guide Ubuntu has, it seems like I'm missing the driver I need. But that doesn't make sense to me because I know I had this driver before. And I also can't find the driver I would need on the Alsa site. When I look at the report for what audio card I have, I get the following:

Audio device: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor HD Audio Controller (rev 06) Subsystem: Hewlett-Packard Company Device 1962 Flags: bus master, fast devsel, latency 0, IRQ 7 Memory at b2710000 (64-bit, non-prefetchable) [size=16K] Capabilities:

00:1b.0 Audio device: Intel Corporation 8 Series/C220 Series Chipset High Definition Audio Controller (rev 04) Subsystem: Hewlett-Packard Company Device 1962 Flags: bus master, fast devsel, latency 0, IRQ 10 Memory at b2714000 (64-bit, non-prefetchable) [size=16K] Capabilities:

I can't find anything matching either of those here. This is bizarre since I know I had this driver before.

  • use the command lspci -v | grep -A 5 "Audio device:" and it should say "Kernel driver in use: . . ." – mchid Jun 5 '15 at 12:39
  • have you tried running sudo alsa force-reload? – mchid Jun 5 '15 at 12:40
  • When I use that first command, I get the same output as what's quoted in my post. Nothing about the kernel driver shows up. – user2435141 Jun 5 '15 at 13:57
  • When I run the second command, it says there are no ALSA sound driver modules to load or unload. In the official troubleshooting guide, it has a command that installs modules, but that command didn't work for me. The error is that it's "Unable to locate package linux-restricted-modules-3.13.0-51-generic" – user2435141 Jun 5 '15 at 14:03
  • That package is extremely outdated and isn't even available for Ubuntu-Precise. Below is a dkms method to autobuild the drivers for all future installed kernels and kernel updates. Please post any errors. – mchid Jun 5 '15 at 15:58
1

In that case, install the ALSA oem-audio-hda-daily-dkms package using the following commands:

sudo add-apt-repository ppa:ubuntu-audio-dev/alsa-daily

press Enter and then execute:

sudo apt-get update
sudo apt-get dist-upgrade
sudo apt-get install --reinstall dkms linux-image-generic linux-headers-generic linux-tools-generic linux-source alsa-firmware-loaders alsa-base alsa-utils alsa-source alsa-tools python-alsaaudio python-pyalsa

reboot, and then run:

sudo apt-get install oem-audio-hda-daily-*
sudo rm /etc/apt/sources.list.d/ubuntu-audio-dev-alsa*
sudo apt-get clean
sudo apt-get autoclean

Reboot and if the drivers aren't loaded, run:

sudo alsa force-reload

Don't forget! When you run

alsamixer

in a terminal, disable automute and then press F6, use the arrow keys and press Enter to select your desired sound card.

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.