1

I'm having an issue when I'm running the proprietary nvidia drivers for my ASUS laptop running ubuntu 14.04. The display freezes periodically (about once every few minutes). I know the system is still running though because I can hear my music still playing, and closing and opening the lid unfreezes the display.

Additionally the problem goes away when I switch to the open source video drivers.

Anyone have a similar experience or know of a solution?

Edit:

00:02.0 VGA compatible controller: Intel Corporation Haswell-ULT Integrated Graphics Controller (rev 09)
Subsystem: ASUSTeK Computer Inc. Device 12dd

Kernel driver in use: i915

04:00.0 3D controller: NVIDIA Corporation GK107M [GeForce GT 745M] (rev a1)
Subsystem: ASUSTeK Computer Inc. Device 12dd
Kernel driver in use: nvidia
6
  • Please edit your question and add output of lspci -k | egrep 'VGA|3D' Net -A2 terminal command. – Pilot6 Jun 4 '15 at 22:21
  • When I added the 'Net -A2' part I got 'egrep: Net: No such file or directory'. So I ran it without that part and updated my question with that result. I'm not sure if that will give the same result though. – Ryan Stull Jun 4 '15 at 22:38
  • do you actually use nvidia propriatary driver indeed or it's nouveau you mean? – JoKeR Jun 4 '15 at 22:39
  • Oh I was using nouveau when I ran that command, should I switch back and run the command? – Ryan Stull Jun 4 '15 at 23:14
  • I mada a typo. It is lspci -k | egrep 'VGA|3D' -A2. The problem looks like your driver is not installed correctly. – Pilot6 Jun 5 '15 at 5:04
0

These freezes happened to me too. It looks like the Nvidia driver from Ubuntu repository does not handle relatively new adapters well.

But also it can be overheat. This also should be considered. I would start with upgrading the driver and kernel this way.

sudo apt-get install linux-generic-lts-vivid

reboot

sudo add-apt-repository ppa:xorg-edgers/ppa
sudo apt-get update
sudo apt-get install nvidia-346 nvidia-settings nvidia-prime
sudo add-apt-repository -r ppa:xorg-edgers/ppa

reboot.

4
  • Running these commands has caused my pc to become unbootable – Ryan Stull Jun 14 '15 at 23:37
  • @RyanStull What you mean "unbootable"? GUI does not start? You can remove this driver from console. – Pilot6 Jun 15 '15 at 7:25
  • Sorry, I switched back to the old kernel and its working once again – Ryan Stull Jun 15 '15 at 14:45
  • You can remove 3.19 kernel image and headers, if they cause problems. – Pilot6 Jun 15 '15 at 14:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.