2

I've been struggling with this one for a while. I have my ASUS K55A Laptop set to "no hibernate to disk" only "suspend to RAM". However, after I close the laptop lid, I still get a black screen. The weird thing is sometimes, after a hard reboot, on the first resume-after-lid-close it DOES resume, however on the second resume-after-lid-close I get a black screen. Also, there are times when I have a YouTube movie playing, and on a resume-after-lid-close which gives me a black screen I can hear the YouTube video playing ("behind" the black screen).

Asus K55A Laptop Ubuntu 14.04.2 LTS Gnome

.---------------.

tom@Toms-Laptop-K55A:~$ free -m
             total       used       free     shared    buffers     cached
Mem:          3839       3733        105        138        170        913
-/+ buffers/cache:       2649       1189
Swap:         3909          0       3909  

.---------------.

When did CTRL + ALT + F1 I got a login prompt. I entered username and password, and then received the appropriate user prompt. Then I did CTRL + ALT + F7 and was presented with the Black Screen.

It's a Black Screen with a Glow, and if I press Fn-F7 (screen off) the glow shuts off. This is the same as when I Reboot and Login, I then see that glowing-black-screen, and then the purplish Gnome Desktop appears.

Since it's a glowing-black-screen that tells me the screen is not off, it is on and "showing me" a black or blank image. .---------------.

Graphics Card lspci | http VGA VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09) .---------------.

  • tom@Toms-Laptop-K55A:~$ /usr/lib/nux/unity_support_test --print
    OpenGL vendor string: Intel Open Source Technology Center
    OpenGL renderer string: Mesa DRI Intel(R) Ivybridge Mobile
    OpenGL version string: 3.0 Mesa 10.1.3
    Not software rendered: yes
    Not blacklisted: yes
    GLX fbconfig: yes
    GLX texture from pixmap: yes
    GL npot or rect textures: yes
    GL vertex program: yes
    GL fragment program: yes
    GL vertex buffer object: yes
    GL framebuffer object: yes
    GL version is 1.4+: yes
    Unity 3D supported: yes
    .---------------.

tom@Toms-Laptop-K55A:~$ sudo lshw -C video
[sudo] password for tom:
*-display
description: VGA compatible controller
product: 3rd Gen Core processor Graphics Controller
vendor: Intel Corporation
physical id: 2
bus info: pci@0000:00:02.0
version: 09
width: 64 bits
clock: 33MHz
capabilities: msi pm vga_controller bus_master cap_list rom
configuration: driver=i915 latency=0
resources: irq:47 memory:f7800000-f7bfffff memory:e0000000-efffffff ioport:f000(size=64)
.---------------.

X.org log file pasted here
http://pastebin.com/Yze9P1Rt
.---------------.

pm-suspend.log. pasted here http://pastebin.com/w20SZ3N2
.---------------.

These links seem like they would be helpful, but they're a bit beyond my technical ability.
https:// 01.org/linuxgraphics/documentation/development/how-debug-suspend-resume-issues
https:// www.kernel.org/doc/Documentation/power/basic-pm-debugging.txt .---------------.

Is it significant that it's a Black Screen with a Glow, and if I press Fn-F7 (screen off) the glow shuts off? .---------------.

Pastebin Diagnostic Files:

  1. X.org log file pasted here http://pastebin.com/Yze9P1Rt

  2. pm-suspend.log. pasted here http://pastebin.com/w20SZ3N2

  3. Output of: sudo systool -m i915 -av http://pastebin.com/X3YKB7zW y .---------------.

1

In my experience, Ubuntu's support for suspend/sleep/other low-power modes is rather hit-or-miss. When I first installed Ubuntu, my custom desktop would suspend just fine, but it wouldn't come out of it to a functional desktop. Some time after rebuilding my system with new hardware, it started working. If I recall correctly, Ubuntu 14.04 is what made it so my computer would suspend and resume correctly. However, on my work computer, an HP Compaq something-or-other also running Ubuntu 14.04, I haven't had any luck with suspend.

Basically, in my experience, Ubuntu sometimes has trouble correctly interfacing with a computer's hardware when it comes to sleeping and resuming. It is completely possible that there is a way to fix such compatibility issues, but I don't know enough to generate a solution, and I may not know enough to comfortably implement such a solution. Unfortunately, that's the best answer I can give, but it's totally possible that some Linux guru may see your problem and come up with a solution.

  • Do you think this could fix the problem? Workaround A: Non-graphical Boot You can disable the graphical bootscreen via: "set gfxpayload=text" wiki.ubuntu.com/X/Troubleshooting/BlankScreen How would I do that? Does that make a non-graphical boot, or a non-graphical session (like without the Ubuntu Gnome graphical user interace)? – user311009 Jun 7 '15 at 14:17
  • That article seems to be talking about a different problem. One of the non-symptoms listed is when it occurs when closing a laptop's lid, suggesting the PipeA Quirk as a more likely possibility. However, something that I have thought of since my initial answer would be to check your BIOS low-power settings. It could be that changing the low-power state in the BIOS might improve compatibility with suspending from Ubuntu. I haven't messed around with such settings, so I'm afraid I may not be very helpful beyond here. – Stephen Kendall Jun 8 '15 at 15:22
  • I've vote this because it clarifies my nebulous suspicions. My Dell laptop running Ubuntu 16.04 has a quite chaotic behaviour after closing the lid and lifting it back later. Sometimes, there is a black screen, sometimes, there isn't. And sometimes, the black screen is so stubborn, that, no matter what keys I press, no matter how long I hover the cursor on the screen, no mater what I do and how long I wait, the black screen is still there and the only way to get read of it is to just press the power button and restart the PC. – Cristiana Nicolae Oct 25 '16 at 6:08

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.