0

I still have the problem with booting Ubuntu on UEFI based laptop (Dell XPS 13, the newest one)

After booting all I can see is a Grub2 console. I tried Boot Repair, but it hasnt helped me at all.

Here is the output that Boot Repair gives: http://paste.ubuntu.com/11572310/

I know that there IS a possibility of installing Ubuntu on this laptop, but fail at every try.

The "place to install bootloader" was the main disc - /dev/sda.

Thanks for any advice!

  • Do not know about XFS partitions, standard is ext4. But you have Windows hibernated or its fast startup still on, you must turn that off if dual booting. You originally installed Ubuntu in BIOS mode as you have a grub in the gpt drive's protective MBR. But it does look like you reinstalled or Boot-Repair converted grub to UEFI boot mode which is what you should have. Since you have Broadwell, best to install 15.04 as it does have newer drivers, but you may even need newer drivers more recent than in distribution. – oldfred Jun 4 '15 at 22:51
  • I have the 15.04 installed. Still - boot repair hasn't fixed my problem - still the grub console... – dziki Jun 5 '15 at 10:31
0

Since Boot Repair doesn't seem to have worked, the next option is my own rEFInd boot manager. It can boot a Linux kernel directly and needs little or nothing in the way of configuration files (unlike GRUB, which requires a very complex configuration file, which is what's not working for you). Download a USB flash drive or CD-R image from the rEFInd downloads page, prepare a boot medium, and try booting it. (You'll probably have to disable Secure Boot, if you haven't done so already -- your Boot Repair output indicates it is disabled, but you may have re-enabled it.) rEFInd should show you options to boot both Windows and Ubuntu. (For Ubuntu, rEFInd will likely show options for both GRUB and direct boots of your kernels.) Try them both. If any of the Ubuntu options works, you can install rEFInd via its PPA or Debian package and you should be good to go. If rEFInd fails, post back with details of what went wrong.


EDIT: Oh, wait, I just noticed that you're using XFS. That will complicate things with rEFInd. Pete Batard's EFI driver package includes an XFS driver. You could add that to the rEFInd USB flash drive and it might work, but I make no promises about that. Switching to ext4fs or Btrfs would give rEFInd a better chance of working, but of course that will require re-installing.

If you do re-install, do so in EFI mode from the start. Installing one OS in EFI mode and the other in BIOS mode is an exercise in pain. Your Windows is in EFI mode, so you should install Ubuntu in EFI mode, too.

|improve this answer|||||
  • I thought I have installed it in EFI mode... it is visible in the efi menu, in the boot options... But is there some trick to start the installation in EFI mode? There will be also no problem with reinstalling and using other partition type... The question is what should I choose in the "Device for boot loader installation".. I hever changed anything there... – dziki Jun 5 '15 at 10:29
  • Your Boot Repair output indicates the presence of both BIOS-mode and EFI-mode copies of GRUB. It's impossible to say from that when each copy was written (during installation, by an earlier run of Boot Repair, or even from an earlier installation, if you did something before the events you relate). Boot Repair ran efibootmgr, though, which means it was booted in EFI mode, so odds are you ran the installer in BIOS mode. If it asked where to install GRUB, it was running in BIOS mode; it doesn't ask this question if you run it in EFI mode. – Rod Smith Jun 5 '15 at 13:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.