1

I installed nginx using apt-get. There are now many folders and files with "nginx" in their name. Using the file browser (nautilus) i search for "nginx" with "All Files" selected.

It will not find anything outside of my home folder. I have restarted and also tried the command updatedb, but it still cant find anything outside my home folder.

How do I change this? It feels like search is broken.

2
  • I think this is a "feature" of nautilus. I also tried searching for bash just now. Once I clicked Computer, and then done search, it worked. So , the search in nautilus basically descends down the folders. If you may understand that better it is doing similar job as find . -name "*nginx*" Jun 4 '15 at 20:00
  • Why are you doing this? There may be an easier solution?
    – Tim
    Jun 4 '15 at 20:26
1

Please make sure that you navigate the nautilus to the parent directory of /home.

For example File System that you can search all of the file in your machine.

To perform search just simply press Ctrl+F.

Please note that: I'm using Ubuntu 12.04 with GNOME 3 Classic.

Source

1

It searches wherever you have selected, the current directory. There are also 2 searches.

This is the first:

Type and it will search the current location, and select the folder with that name. If there are multiple with the same starting with the current search, it will chose the first by current sorting (alphabetically by default).

Then there is the real search, to search the folder and all files / folders in it:

To access this, click the search icon, in the top bar.

Here, you are searching "Home" by default. You want to search a different folder, so there are 2 ways to get that:

  • If you want to search from the root directory, all the computer (/) click All Files.

  • If you want to search a certain folder, navigate there and then use the search tool.

Your question sounds like you want to search everywhere (although I'm not sure why). So click the All Files at the top, or click Computer at the side, and then do your search.


As an alternative, install nemo:

sudo apt-get install nemo

It is based on the same code as nautilus, but may work when nautilus doesn't.

9
  • As I have pointed out in my question, this does not work. Jun 4 '15 at 20:22
  • @user3731825 did you try my other solution? Click computer then search? Are you sure there is a file with that name?
    – Tim
    Jun 4 '15 at 20:23
  • You are not sure why someone would want to search everywhere? I find that very strange. Doesn't my question imply that I'm looking for folders associated with nginx? Jun 4 '15 at 20:24
  • @user3731825 yes, it does make it clear what you're doing. I'm confused why you need to search for it - there may be a way to achieve what you're doing without searching with Nautilus.
    – Tim
    Jun 4 '15 at 20:25
  • Yes I am sure that I am searching from root and clicking on the "All Files" button. This does not change anything. Jun 4 '15 at 20:26
1

The search isn't broken. But for a systemwide search it's better to use more powerful tools like locate or find in a terminal.


For a systemwide search with Nautilus you have to change the location to /. Open the location bar with Ctrl+L and enter / and press Enter. After that start the search again with Ctrl+F. Additionally check the search settings in your system settings. There you can exclude or include folders.


For an efficient system-wide search using the terminal, press Ctrl+Alt+T and type:

find / -type d -iname "*nginx*"

The command starts a search in the root of your file system an searches all folders with nginx in the name.

locate fstab

Search for fstab, a file in /etc.

If you still do not find a folder or file, then start the search with sudo

sudo find / -iname "*nginx*"

Read the man pages for these commands

man find
man locate
6
  • (Thank you for the working command line answer.) Your suggestion about using ctr+l and entering / (i beleive is no different than simply navigating to root by clicking "Computer") does not work Jun 4 '15 at 20:20
  • @user3731825 That's true, but I'm faster with the keyboard than with the mouse.
    – A.B.
    Jun 4 '15 at 20:24
  • So the question remains unanswered. Can you explain how this does not make nautilus search broken? Jun 4 '15 at 20:27
  • I have updated my answer. Start a search with sudo find ...
    – A.B.
    Jun 4 '15 at 20:34
  • It works when I avoid clicking "All Files". So nautilus search is not broken, just the "All Files" button. Jun 4 '15 at 20:41
0

To make nautilus search all files, simply avoid clicking "All Files". So nautilus search does indeed work, its the "All Files" button that does not. -update- I can not reproduce this. The / always becomes "Home" and the "All Files" button active. I am using Nemo instead of Nautilus now. (suggested by Tim)

5
  • All files works for me, and searches everywhere: imgur.com/YNb9RTR (albeit slowly)
    – Tim
    Jun 4 '15 at 20:47
  • doesn't for me, and it seems tricky to even get the / option. it tends to switch to Home imgur.com/UVgq3Yz Jun 4 '15 at 21:00
  • You sure there is a file with that name?
    – Tim
    Jun 4 '15 at 21:01
  • yes, for example the file nsswitch.conf is in the /etc directory imgur.com/T5feI9E I now click on "Computer" imgur.com/TiJMutw (notice the / next to "All Files") after entering "nsswitch.conf" the / is now "Home" imgur.com/HgzjdJ2 and there is no way to search for the file. Even following A.B.'s suggestion of using control+l and control+f is no help. I don't know how I made it work earlier. It is, without a doubt, broken. Nemo is working great btw. thank you. Jun 4 '15 at 21:11
  • okay, no more suggestions I'm afraid. Glad nemo works!
    – Tim
    Jun 4 '15 at 21:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.