1

I'm using Intel's on-board audio (ALC892 Analog) and it works fine, it can output non-surround sounds into rear speakers. However, when I try to play a movie with an 5.1 audio track, or a standalone audio file with 5.1 channels, I'm either don't get sound in the rear speakers or get the wrong sound (it mixes front channels into the back).

I've tried the pre-installed video player, Kodi and VLC, And the results are the same. In VLC by setting output to Alsa and choosing 7.1 channels, I've managed to get correct sound in rear speakers with the test audio file, however in that configuration, the center and sub-woofer were silent.

I've also tried to edit a pulseaudio config file, swapping rear and mid speakers in the 7.1 profile, to no avail.

And the most odd thing: with DTS codec I get proper sound from the rear speakers, but not with FLAC and AAC.

Thanks in advance!

0

Open alsamixer in a terminal:

alsamixer

press F6 and select your sound card by using the arrow keys and then press ENTER.

The first thing you need to do is turn automute off (use the arrow keys) and then find the back speaker and increase the volume. Press Esc to exit the alsamixer.

0
0

I've managed to get it work.

The problem wasn't with Linux, Alsa or PulseAudio, the problem was with my setup.

My PC is capable of 7.1 audio on-board, but I have an 5.1 speaker set directly hooked into my computer (analogue out). Also, under Windows, real sound from the rear speakers only heard if I plug the rear jack into the side plug. Under Ubuntu, Alsa or pulse correctly recognizes my machine's 7.1 capability and assumes that I have a 7.1 speaker system. The speakers are recognized correctly, but real surround rear stream is flowing into the side speakers, instead of rear, even if choose the 5.1 analogue output in the sound settings applet. Then rear speakers are mapped as side speakers.

To get real surround sound, I've also had to do the following:

  • Set Totem Media Player to 5.1 output Edit | Settings | Sound tab
  • Install the Pulse Audio Volume Control. (sudo apt-get install pavucontrol) and adjust the side speaker's volume. Real surround sound, especially the rear channels, is usually low volume. It's recommended to first start the movie/audio and seek to a loud part before you do this, though.
  • Also, you have to adjust volume in the output tab, because you can only adjust rear speakers there.
  • DO NOT touch the regular volume control indicator while pavucontrol is running, or even after you ran it. it'll behave erratically!

Edit 15 aug 2015: Since then, I've mustered the courage and plugged the rear speakers' jack into the correct plug, and set mode to 5.1. It works flawlessly with the test file. The problem was with 7.1 mode with rear speakers plugged into the side plug is that that in that mode side speakers gets a mixed channel from the front and back channels via pulse. With this physical correction, Ubuntu's sound settings applet also becomes more useful, so you may not need pavucontrol.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.