1

I have ubuntu 14.04.2 with both nvidia geforce 860m as well as intel.

lspci
00:00.0 Host bridge: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor DRAM Controller (rev 06)
00:01.0 PCI bridge: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor PCI Express x16 Controller (rev 06)
00:02.0 VGA compatible controller: Intel Corporation 4th Gen Core Processor Integrated Graphics Controller (rev 06)
Audio device: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor HD Audio Controller (rev 06)
00:14.0 USB controller: Intel Corporation 8 Series/C220 Series Chipset Family USB xHCI (rev 05)
00:16.0 Communication controller: Intel Corporation 8 Series/C220 Series Chipset Family MEI Controller #1 (rev 04)
00:1a.0 USB controller: Intel Corporation 8 Series/C220 Series Chipset Family USB EHCI #2 (rev 05)
00:1b.0 Audio device: Intel Corporation 8 Series/C220 Series Chipset High Definition Audio Controller (rev 05)
00:1c.0 PCI bridge: Intel Corporation 8 Series/C220 Series Chipset Family PCI Express Root Port #1 (rev d5)
00:1c.1 PCI bridge: Intel Corporation 8 Series/C220 Series Chipset Family PCI Express Root Port #2 (rev d5)
00:1c.2 PCI bridge: Intel Corporation 8 Series/C220 Series Chipset Family PCI Express Root Port #3 (rev d5)
00:1c.4 PCI bridge: Intel Corporation 8 Series/C220 Series Chipset Family PCI Express Root Port #5 (rev d5)
00:1d.0 USB controller: Intel Corporation 8 Series/C220 Series Chipset Family USB EHCI #1 (rev 05)
00:1f.0 ISA bridge: Intel Corporation HM86 Express LPC Controller (rev 05) 00:1f.2 SATA controller: Intel Corporation 8 Series/C220 Series Chipset Family 6-port SATA Controller 1 [AHCI mode] (rev 05)
00:1f.3 SMBus: Intel Corporation 8 Series/C220 Series Chipset Family SMBus Controller (rev 05)
01:00.0 3D controller: NVIDIA Corporation GM107M [GeForce GTX 860M] (rev a2)
08:00.0 Network controller: Intel Corporation Wireless 7260 (rev 83)
09:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 10)
0a:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. Device 5249 (rev 01)

in the system-> details i see "Intel® Haswell Mobile" in the graphics.
i want to install cuda. i downloaded cuda-repo-ubuntu1404_7.0-28_amd64.deb from developer.nvidia.com/cuda-downloads
i followed the next link github.com/facebook/fbcunn/blob/master/INSTALL.md and did:

sudo apt-get install build-essential
sudo dpkg -i cuda-repo-ubuntu1404_7.0-28_amd64.deb sudo apt-get update
sudo apt-get install cuda
echo "export PATH=/usr/local/cuda/bin/:\$PATH; export LD_LIBRARY_PATH=/usr/local/cuda/lib64/:\$LD_LIBRARY_PATH; " >>~/.bashrc && source ~/.bashrc

then when i reboot the computer, the laptop gets stuck with the ubuntu logo just before login.
why is that? i tried to understand why is that, and got confused. do i need to install nvidia drivers before doing so, or does cuda install kit already includes it?
i tried to install the drivers using ppa-xorg edgers following this link http://www.binarytides.com/install-nvidia-drivers-ubuntu-14-04/ . i managed to install the drivers, and reboot. and then tried to install cuda again the same way and got the same problem. or is it because i have hybrid gprahic, both intel and nvidia? if so i can fix it? each time it happens, i end up reinstalling ubuntu.
i only care about getting cuda working.

0

I suggest you to use the installer (.run file) from Nvidia's website and run it in text mode. I have almost the same specifications and here is what I have done for installing CUDA [link].

If you follow my steps, you will use Intel for display and Nvidia for computing. It has been working fine on my laptop for many month.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.