0

I'm trying to install magento in my ubuntu system. Once I installed the php5-mcrypt plugin successfully. But the Magento installation wizard was still showing the warning message "mcrypt is not loaded" meanwhile the php5 -m shows the mcrypt is already loaded. I tried some experiments like this but it didn't work.

Inbetween some workarounds, I modified some mcrypt.ini files (don't remember what exactly I did. sorry). At some point I purged out the php5-mcrypt pluign. Now the problem is that, I'm not even able to reinstall the php5-mcrypt. When I 'apt-get install php5-mcrypt , it shows

(Reading database ... 214103 files and directories currently installed.) Preparing to unpack .../php5-mcrypt_5.4.6-0ubuntu5_amd64.deb ... Unpacking php5-mcrypt (5.4.6-0ubuntu5) ... dpkg: warning: php5-mcrypt: config file 'etc/php5/mods-available/mcrypt.ini' is a circular link (= '/etc/php5/cli/conf.d/20-mcrypt.ini') dpkg: error processing archive /var/cache/apt/archives/php5-mcrypt_5.4.6-0ubuntu5_amd64.deb (--unpack): unable to open '/etc/php5/mods-available/mcrypt.ini.dpkg-new': No such file or directory No apport report written because the error message indicates an issue on the local system Errors were encountered while processing: /var/cache/apt/archives/php5-mcrypt_5.4.6-0ubuntu5_amd64.deb E: Sub-process /usr/bin/dpkg returned an error code (1)

I tried even after re installing php and all other components as in this tutorial but still same problem exist. I'm not able to figure out the issue. I'm using ubuntu 14.04. Please help

1 Answer 1

0

Try removing /etc/php5/mods-available/mcrypt.ini and /etc/php5/cli/conf.d/20-mcrypt.ini in case any of them still exist and then try installing it again with apt-get

sudo rm -f /etc/php5/mods-available/mcrypt.ini

sudo rm -f /etc/php5/cli/conf.d/20-mcrypt.ini

The problem should be coming from the first file, but delete the second one as well just to be sure.

1

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .