So I've looked at many of the other forums but nothing I've seen so far has eliminated my issue. As soon as I boot up my laptop, Lenovo T440s, I start hearing a pop then a loud continious hiss that seems to cut out anytime the sound adjusted. This only happens when I boot into Ubuntu, when I boot into windows I do not have this issue.

I tried muting my mic, I tried alsamixer, neither worked. The pop and hissing does not happen over speakers, only headphones, and it happens with the same intensity no matter what my volume setting is, even when it's on mute.

When I open 'sound settings' it stops, but nothing I've done there has prevented it coming back. The only thing so far that stops it is if I have other sounds playing. It almost seems like it is a result of the soundcard not being used. Any ideas out there? or forums that already dealt with this that I did not see? Thanks


This might be the Intel sound card entering power save mode. Check whether power save in currently enabled via:

    cat /sys/module/snd_hda_intel/parameters/power_save

If this returns 1, power save is enabled; it returns 0 otherwise. Check to see if changing this solves your problem by runnning

    echo 0 | sudo tee /sys/module/snd_hda_intel/parameters/power_save

Then play some music, pause it and see if the noise returns. If the problem persists, it's something else.

If this does get rid of the noise, you'll find it's only temporary, since the value can be reset on reboot or on switching between battery to AC power. A few different services could be changing this value, so try configuring each of them:


To /etc/modprobe.d/alsa-base.conf, add the line:

    options snd-hda-intel power_save=0


To /usr/lib/pm-utils/power.d/intel-audio-powersave, add or uncomment the line: INTEL_AUDIO_POWERSAVE=false


If installed, in /etc/default/tlp, set the following:

  • 1
    This worked for me (Ubuntu 16.04 on Dell XPS 13 9360) Mar 13 '17 at 5:25
  • worked for me too on arch linux.
    – BladeMight
    May 1 '18 at 17:08
  • Worked for me too (Desktop with Ubuntu 18.04)
    – ferhoyo
    Jan 25 '20 at 11:00
  • Worked for me on Pop!OS 19.10 on my Xiaomi Mi Notebook Pro! Realtek ALC298 / Xiaomi Sunrise Point-LP HD Audio
    – Kev
    Apr 3 '20 at 19:22
  • Worked for me on Fedora 34.
    – thesdev
    Jul 22 at 6:21

I was searching for solutions to this issue online and I found a topic that dealt with it. Based on the original answer I found, the most persistent method was to edit my


I added to the end of the start and reset sections the following:

if [ -f /sys/module/snd_hda_intel/parameters/power_save ]
    log_action_begin_msg "Trying workaround for Intel HDA..."
    echo 0 >/sys/module/snd_hda_intel/parameters/power_save
    log_action_begin_msg "Not using Intel HDA workaround"

and change the top of the script from #!/bin/sh to #!/bin/bash

All it does is check if the Intel HDA power_save file exists and puts 0 into it. If not (like my 6-hour-power field-service portable) then gracefully announces it'll not use the work around.

It must have to do with awkward and bespoke hardware designs as the latest distros (late 2016) out there still do this to my "portable desktop". However, this fix so far works on most Ubuntu/Debian derivatives and some other distros (with my hardware AFAIK).

P.S. This may be good Wiki material as I've commonly seen this happen on several "portable Desktop" type laptop machines with complex (2.1, 5.1 etc) sound-systems.

Name suggestion: Hissing Speaker Fixes

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.