I have just installed Ubuntu 15.04 with no Internet access, my WiFi dongle has been assigned an rtl8171 module although it is apparently using a generic driver.

I can enter my WiFi password, but then it just shows the connecting animation forever.

Once it told me that it had connected to the home network, but that didn't seem to mean much - it continued connecting, and still no Internet access.

I'd like to know how to ensure it is using a valid driver.

Output from lsusb && usb-devices follows.

Bus 001 Device 007: ID 0bda:8187 Realtek Semiconductor Corp. RTL8187 Wireless Adapter
Bus 001 Device 006: ID 058f:6362 Alcor Micro Corp. Flash Card Reader/Writer
Bus 001 Device 005: ID 0bda:8176 Realtek Semiconductor Corp. RTL8188CUS 802.11n WLAN Adapter
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 003: ID 046d:0a19 Logitech, Inc. 
Bus 002 Device 002: ID 046d:c019 Logitech, Inc. Optical Tilt Wheel Mouse
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

T:  Bus=01 Lev=01 Prnt=01 Port=05 Cnt=01 Dev#=  5 Spd=480 MxCh= 0
D:  Ver= 2.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs=  1
P:  Vendor=0bda ProdID=8176 Rev=02.00
S:  Manufacturer=Realtek
S:  Product=802.11n WLAN Adapter
S:  SerialNumber=00e04c000001
C:  #Ifs= 1 Cfg#= 1 Atr=80 MxPwr=500mA
I:  If#= 0 Alt= 0 #EPs= 4 Cls=ff(vend.) Sub=ff Prot=ff Driver=rtl8192cu

T:  Bus=01 Lev=01 Prnt=01 Port=08 Cnt=03 Dev#=  7 Spd=480 MxCh= 0
D:  Ver= 2.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs=  1
P:  Vendor=0bda ProdID=8187 Rev=01.00
S:  Manufacturer=Manufacturer_Realtek_RTL8187_
S:  Product=RTL8187_Wireless
S:  SerialNumber=0015AF6522B4
C:  #Ifs= 1 Cfg#= 1 Atr=80 MxPwr=500mA
I:  If#= 0 Alt= 0 #EPs= 3 Cls=00(>ifc ) Sub=00 Prot=00 Driver=rtl8187
  • Please edit your question and add output of lsusb && usb-devices terminal command.
    – Pilot6
    Jun 4, 2015 at 15:43
  • And rtl8171 is a wired Ethernet driver. it is unrelated.
    – Pilot6
    Jun 4, 2015 at 15:49
  • It's coming, I just need to transfer it to a computer with Internet (can't access my phone)
    – Jaybird
    Jun 5, 2015 at 9:49
  • Done - sorry for the delay and formatting, I got it going through my phone, but not the code style blocks.
    – Jaybird
    Jun 7, 2015 at 13:45
  • It looks like you have two USB adapters connected. Is it the case?
    – Pilot6
    Jun 7, 2015 at 13:48

2 Answers 2


It looks like you have two Realtek adapters connected to USB.

Regarding 0bda:8176 Realtek Semiconductor Corp. RTL8188CUS 802.11n WLAN Adapter you can install a better driver. Run in terminal

   sudo apt-get install git build-essential
   git clone https://github.com/lwfinger/rtl8192cu.git
   cd rtl8192cu
   sudo make install

It should solve the issue.

You will have to re-install this driver after each kernel upgrade.

I pushed DKMS module of this driver to my ppa. If you install it from there, you will not need to re-install it.

It can be installed by

sudo add-apt-repository ppa:hanipospilot/rtlwifi
sudo apt-get update
sudo apt-get install rtl8192cu-dkms

Important!!! If you previously installed this driver from https://github.com/lwfinger/rtl8192cu.git, you will need to run

sudo rm /etc/modprobe.d/50-rtl8192cu.conf

to get it work. Previous install blacklists rtl8192cu.

And if you installed rtlwifi-new-dkms, you should remove it too.

I will later remove rtl8192cu from rtlwifi-dkms, because it does not work well.

  • Now when I connect to the WiFi, the whole computer freezes indefinitely, I tried restarting three or four times with the same result.
    – Jaybird
    Jun 8, 2015 at 5:59
  • OK. I know how to fix it. First run sudo apt-get remove rtlwifi-new-dkms && sudo add-apt-repository -r ppa:hanipouspilot/rtlwifi
    – Pilot6
    Jun 8, 2015 at 9:27
  • And then install another driver from the answer.
    – Pilot6
    Jun 8, 2015 at 9:32

I solved it. You can try:

sudo apt-get install linux-firmware


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .