2

This is about Lubuntu 15.04 vivid which is a system upgrade from 14.10

I have a problem adding news apps to the application launch bar because the new apps don't show.

I installed apps like VLC player, Skype, Chromium etc. I want to add these apps to the application launch bar. Going to add/remove panel items, then click application launch bar and preferences. The small file manager window shows up with left the launchers and right the installed applications. So far all good. However, none of newly installed apps is showing on the right. So I can not add them to the application launch bar. The new apps do show in the normal menu and they work fine but that doesn't matter or help for this issue.

As I just discovered, the same happens if I want to set a default application for opening a file, e.g. VLC to open a MP4 video file.

  • Look into /usr/share/applications directory. For all (or most ) of the installed apps, you have .desktop files. If you can find a .desktop files for those apps, you can then create a link, place it on desktop, and then pin it to launch bar. If you don't find it, try using which skype and which chromium-browser in terminal. That should let you know where the binary files are located, in fact, I'm 99% certain it will say /usr/bin. – Sergiy Kolodyazhnyy Jun 5 '15 at 10:51
  • I'm sorry but I can't pin links from the desktop to the launch bar. The .desktop files are in /usr/share/applications but is this where Panel Preferences is looking? If it is why doesn't it see the recent files? If it is not, then where is it looking? – Vansloneker Jun 6 '15 at 14:10
  • OK, so what did you find ? did you find .desktop files for your specific applications ? Did you find the executable ( binary ) files ? – Sergiy Kolodyazhnyy Jun 6 '15 at 14:30
  • Well I have already confirmed the .desktop files and I can also confirm the /usr/bin location but this does not make me pin the apps to the application launch bar. – Vansloneker Jun 6 '15 at 20:01
  • How about copying the files to desktop and then trying to pin the apps ? By default they're should be owned by root. A copy is owned by your username, so that should work – Sergiy Kolodyazhnyy Jun 6 '15 at 20:10
1

Try this:

cp /usr/share/applications/app.desktop ~/.local/share/applications/

And then check Application Launcher Bar again and it will appear. It works for me!

0

I've run into same problem, and what fixed it for me was making .desktop file avaliable to all users, that is:

chmod 777 /user/share/applications/<theapp>.desktop

After doing that it appeared among the apps you can choose in the "Application Launch Bar" settings.

0

It seems that "Application Launch Bar" starts to see some *.desktop files after any change to their permissions. So, you can change permissions for /usr/share/applications/<app>.desktop and then change it back again. You can, for example, set the execution bit, save the changes and the drop that bit back. I did it in Midnight Commander run under superuser:

sudo mc

and then going to File, Advanced chown

0

It seems that Stanislav and Uto_dev are in the good way. The problem is date of file.

This was my solution:

touch /usr/share/applications/<app>.desktop

This changes modification time of file to 'now'. After this I can see application and add it to panel.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.