0

I have a Zenbook UX21 and I'm not able to get bluetooth up and running. I've just installed blueman and bluez, but I'm still not able to connect devices because they are not found.

uname -a

Linux daniel-UX21E 3.19.0-18-generic #18-Ubuntu SMP Tue May 19 18:31:35 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

lsusb | grep -i "bluetooth"

Bus 003 Device 006: ID 13d3:3375 IMC Networks Atheros AR3012 Bluetooth 4.0 Adapter

hcitool dev

Devices:

(empty list)

rfkill list

0: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no
1: asus-wlan: Wireless LAN
Soft blocked: no
Hard blocked: no
2: asus-bluetooth: Bluetooth
Soft blocked: no
Hard blocked: no
3: hci0: Bluetooth
Soft blocked: no
Hard blocked: no

Edit: Jeremy helped me to fix my problem temporary (sudo hciconfig hci0 up).

Unfortunately, Bluetooth is not working after I restarted my notebook. hciconfig -a does not list a device, all other commands return the same as before (see comments below). I had to start the bluez daemon manually.

sudo /etc/init.d/bluetooth status -l

says

bluetooth.service - Bluetooth service
  Loaded: loaded (/lib/systemd/system/bluetooth.service; enabled; vendor preset: enabled)
  Active: active (running) since Mit 2015-06-10 09:10:33 CEST; 30min ago
Main PID: 3096 (bluetoothd)
  CGroup: /system.slice/bluetooth.service
       └─3096 /usr/sbin/bluetoothd -n
  • Do you see a list of files using this command ls /lib/firmware/ar3k Also do modprobe -c | grep 3375 | grep ath3k does terminal return ath3k? – Jeremy31 Jun 4 '15 at 10:21
  • Yes I do. Everything seems to be fine. – Daniel Jun 4 '15 at 11:11
  • Any errors reported in dmesg | grep -i firmware; dmesg | grep -i bluetooth – Jeremy31 Jun 4 '15 at 11:22
  • everything, except the first line seems quite good: [ 0.143444] [Firmware Bug]: ACPI: BIOS _OSI(Linux) query ignored – Daniel Jun 4 '15 at 12:21
  • And that firmware bug is normal. Was there anything else? – Jeremy31 Jun 4 '15 at 20:48
1

From your comments, getting bluetooth working should just involve

sudo hciconfig hci0 up

Since it seems to forget this setting after a reboot

gksudo gedit /etc/udev/rules.d/90-bluetooth.rules

and paste the following into the file

ACTION=="add", KERNEL=="hci0", TEST=="/usr/sbin/hciconfig", RUN+="/usr/sbin/hciconfig hci0 up"

Save, exit program and reboot to test

  • It works like a charm now. Thank you so much for your help, Jeremy! – Daniel Jun 8 '15 at 15:26
  • But I'm not sure if it's really solved since it's not working properly. After rebooting my notebook it is not working anymore... – Daniel Jun 10 '15 at 10:01
  • Are you using Kubuntu? – Jeremy31 Jun 10 '15 at 10:06
  • Nope. It's Ubuntu. – Daniel Jun 10 '15 at 14:19
  • @Daniel Is it blocked by rfkill? – Pilot6 Jun 10 '15 at 14:26
0

Try to install new firmware for this device.

You can download it from HERE

It can also be installed by adding ppa

 sudo add-apt-repository ppa:hanipouspilot/rtlwifi
 sudo apt-get update
 sudo apt-get install linux-firmware
  • Blueman still says that no adapters were found. – Daniel Jun 10 '15 at 17:14
  • @Daniel You need to turn off the computer (not reboot) and turn it on again after you added the firmware. – Pilot6 Jul 6 '15 at 12:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.