3

I've been using Ubuntu for years. Now, I'm in version 14.04, alternating with some sessions in ubuntu-desktop and others in xubuntu-desktop. A few days ago, when "playing" with some themes and with changing to Nvidia drivers, suddenly, the fonts in Thunderbird and in Firefox got thin and ugly. I don't know exactly what caused this, themes or drivers. With lots of hours (days...) of Google search and tests, I've no success...

I already did changes in Firefox and TB preferences of fonts, and it solves in part. But why change now some defaults in this apps, if until now everything was looking good? For example, in a fresh Ubuntu/Xubuntu install, we don't need to change that defaults!

Any chance to solve this, keeping the default of that apps?

  • 2
    check this one it might help you askubuntu.com/questions/478130/firefox-doesnt-show-texts/… – JoKeR Jun 3 '15 at 23:02
  • I added information, because I already have done that, but is not what I was looking for. – R. Cardoso Jun 4 '15 at 19:28
  • 1
    it's because it depends on theme environment that you use, most of the themes are created free and open to use, though they do not guarantee you the best look with no possible issues. For example did you notice this to happen to the themes which ship with Ubuntu by default? – JoKeR Jun 4 '15 at 22:25
  • Thank you, @JoKeR. As I said, it was looking good, before "playing" with themes and trying Nvidia drivers. So, my conclusion is: "If you are not an expert, don't change nothing. Or live with the consequences!". :) – R. Cardoso Jun 5 '15 at 18:01
1

For firefox go to Edit -> Preferences:

Choose Content

Content

Then Choose Advanced

advanced

Clear the checkbox (shown above) and choose the font settings you want.

For Thunderbird Edit -> Preferences and adjust the font choice under HTML to your liking.

tbird-fonts

Sources: Comment from @JoKeR and Firefox and Thunderbird preferences

  • Thank you for your effort and clear instructions. But I was looking for a solution in Ubuntu system, not in changing defaults of that apps. In a fresh install of Ubuntu, we don't need to change that apps defaults. – R. Cardoso Jun 4 '15 at 19:33
  • I'm sorry this wasn't the answer you were looking for, It is however a solution that will work. Perhaps someone else with the same problem will find it more to their liking. Since your question doesn't provide any useful information on what you did to get to where you are, it's unlikely that anyone can tell you how to undo what you did. I suggest that you review askubuntu.com/help/how-to-ask especially the last section. – Elder Geek Jun 5 '15 at 14:41
  • Thank you @Elder. I have said all information I have. Is not enough? OK, this is a lost case. – R. Cardoso Jun 5 '15 at 17:52
  • I believe you have misunderstood. Likely due to the fact that you didn't read what I suggested that you review. Be that as it may, it's still feasible that someone else may come up with an answer that is more to your liking. I was simply pointing out that just because an answer isn't exactly what you expected or wanted doesn't mean it's wrong. – Elder Geek Jun 6 '15 at 17:21
0

Install Unity Tweak Tool and try the "restore defaults" option under the "Fonts" setting. Normally high hinting values will cause the "thin"-looking typeface rendering. Also, take a look at this:https://wiki.ubuntu.com/Fonts#Font_settings

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.