8

New Problem

I am now able to access the internet but, when I connect to netgear router NO data is recieved and I can't also ping my router.This does not happen with any other router like DLINK or my phone's HOTSPOT. PLEASE can anyone help where the problem is.

The below problem is solved.

I have Sony vaio laptop having installed Ubuntu 14.04 on it. Laptop can connect to the wifi router but when browser is opened I get the Web page is not available error.

I did

$ ping google.com
ping: unknown host google.com

I ping my laptop. That returned success. But when I ping some other IPs it says destination host unavailable

This error started since I hard reset my router

[Edited]

$ lspi -knn | grep Net -A2
02:00.0 Network controller [0280] : Qualcomm Atheros AR9485 Wireless Network Adapter [168c:0032] (rev 01)
Subsystem : Foxconn Interntional , Inc Device [105b: e044]
kernel driver in use : ath9k

I think I have messed up some thing because of trying too many solution. Is there any way like we have factory reset in mobile phones...so that I can be able to start again. One thing I can

ping 8.8.8.8

with 100% success

Edited 2015-06-05

This is what I tried on terminal

sudo lshw -c network
ifconfig
sudo service network-manager restart
sudo service networking restart
sudo /etc/ini.d/networking restart
sudo ifconfig wlan0 down
sudo service networking restart
sudo /etc/init.d/networking restart
sudo ifconfig wlan0 down
sudo ifconfig wlan0 up
sudo apt-get remove --purge resolvconf
sudo dpkg --configure -a
lspci -knn | grep Net -A2
lsb_release -rcd ; uname -r;
lspci -nnk  | grep -iA2 net
lsmod rfkill list all nmcli nm status
nmcli nm enabled true
echo 'options ath9k nohwcrypt=1' sudo tee /etc/modprobe.d/ath9k.conf
rfkill list

Output of route -vn

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         192.168.1.1     0.0.0.0         UG    0      0        0 br0
169.254.0.0     0.0.0.0         255.255.0.0     U     1000   0        0 br0
192.168.1.0     0.0.0.0         255.255.255.0   U     0      0        0 br0

The command ping 192.168.1.1 does not give anything! After some time I press Ctrl+C and all this gives me 100% data loss.

How should I proceed?

  • Comments are not for extended discussion; this conversation has been moved to chat. – Mitch Jun 5 '15 at 20:29
7

Hello To all those viewed this post. This issue was solved. People commenting on the post made me to detect the point where the error was caused.

This is what I made mistakes

I unistall the resolvconf file

And then I tried some one's answer, Which suggested that to change the Proxy settings of the Network. I did as per his suggestion.

Then People on Reddit suggested to again install the resolvconf file. I installed manually.

But then the issue was with the Proxy change I did it. He then suggested me to change it to none and Boom the problem was solved.

And really I made so many wrong changes that I did in terminal as listed above.

Today What I learned is, first check the command for which purpose it is used to execute and then execute.

Hearty Thanks to all once again

Solved

  • 1
    The best part of this is "first check the command for which purpose it is used to execute and then execute." Bravo – Elder Geek Jun 12 '15 at 12:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.