6

My PC is using ubuntu 14.04, and I need install Atlas.

Atlas says: it need to disable CPU throttling, I have done the job to disable it.

cat /sys/devices/system/cpu/cpu{0,1,2,3}/cpufreq/scaling_governor
performance
performance
performance
performance

But when I was running this command to install Atlas:

../configure -b 64 -D c 2400 --prefix=/home/azhen/lib/atlas --with-netlib-lapack-tarfile=/home/azhen/Downloads/lapack-3.4.1.tgz

It says:

CPU Throttling apparently enabled!
It appears you have cpu throttling enabled, which makes timings
unreliable and an ATLAS install nonsensical.  Aborting.
See ATLAS/INSTALL.txt for further information

Can someone help me take a look?

  • cpufreq-info analyzing CPU 0: driver: intel_pstate CPUs which run at the same hardware frequency: 0 CPUs which need to have their frequency coordinated by software: 0 maximum transition latency: 0.97 ms. hardware limits: 1.60 GHz - 3.60 GHz available cpufreq governors: performance, powersave current policy: frequency should be within 1.60 GHz and 3.60 GHz. The governor "performance" may decide which speed to use within this range. current CPU frequency is 2.20 GHz. – Azhen Feixue Jun 3 '15 at 12:58
  • Before diving down this (potential) rabbit hole, is there a particular reason you can't use the pre-built atlas library from the repository? – steeldriver Jun 3 '15 at 13:17
  • Hi Steeldriver,thank you for your comments, but seems there is not pre-built binary. Can I download a prebuilt binary instead of installing from source? Unfortunately, we lack the manpower to provide prebuild binaries. From its help doc: math-atlas.sourceforge.net/faq.html#help – Azhen Feixue Jun 3 '15 at 13:39
  • Well, the libatlas-dev package (and it's dependency libatlas-base-dev) should provide the header files and libraries necessary to build applications using atlas: is that what you need to do? If not, please explain what your end goal is - are you trying to install some other software that depends on atlas? – steeldriver Jun 3 '15 at 14:15
  • I am trying to use caffe.berkeleyvision.org, that needs Atlas. – Azhen Feixue Jun 4 '15 at 2:41
4

I am a fairly recent Ubuntu user and not a computer expert and I was having exactly the same problem as you. After some struggling, I managed to avoid the message "CPU Throttling apparently enabled!" and got ATLAS 3.10.2 installed.

The first tip I got in https://sourceforge.net/p/math-atlas/support-requests/859/#f11d, where it basically says that "The only time ATLAS should detect throttling that isn't occurring is when the processors are fixed to run at a lower speed than their maximum speed." My processor was not running at its maximum speed, since I had a BIOS speed limit.

If you have the same problem, look at the maximum frequency allowed in the file /sys/devices/system/cpu/cpu0/cpufreq/scaling_max_freq. Copy this value to the files for each processor(/cpu/cpu1, /cpu/cpu2 etc). You need to do it as super-user, but before it takes effect, you have to edit the file /sys/module/processor/parameters/ignore_ppc from 0 to 1. More details are given here.

This was still not enough for me and I figured out that I had to edit the files /sys/devices/system/cpu/cpu0/cpufreq/scaling_min_freq to the same value that was used before. After that, I did not get the boring message any more and ATLAS was successfully installed!

update: I have just gone through this process again and it seems that the real problem is to have the power scaling driver intel p_state enabled. The procedure above will only work if you disable it first. Follow the instructions in here and replace "enable" by "disable" as explained here.

1

I followed the Caffe installation guide for ubuntu where it is written that one can install BLAS by

sudo apt-get install libatlas-base-dev

0

Building ATLAS from source is necessary for Ubuntu 16.04. In addition to what Filipe wrote, I had to disable ACPI in GRUB, which was the root of the throttling issue (link). I disabled Intel pstate too, since both were installed. I then updated GRUB, which removed all of the CPU throttling files mentioned by Filipe. Here was my process (follow at your own risk):

nano /etc/default/grub
GRUB_CMDLINE_LINUX_DEFAULT="text acpi=off intel_pstate=disable"
save
update-grub
reboot

The scaling drivers should now be absent, which you can test with this command:

cat /sys/devices/system/cpu/cpu*/cpufreq/scaling_driver

Keep in mind that this turns off power and temperature management systems. You may want to turn pstate back on after installing.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.