1

Is there a way to install old packages of the following versions:

apache2: 2.2.12

mysql: 5.1.37

PHP 5.2.10

on Ubuntu 12.04, i386, using apt-get or dpkg?

  • As an alternative, I would suggest you look into virtual machines or containers (LXC, docker, etc.) to setup a specific setup – chesedo Jun 4 '15 at 6:53
1

First you should notice that apache2.2.12 has many security vulnerabilities

Now in general you can downgrade a package version in Ubuntu, but you should notice that the version must be available in the software channels(your repositories). To show the available versions for some package run the command:

apt-cache showpkg <package-name>

Now to downgrade a package select the version you want then:

sudo apt-get install <package-name>=<package-version-number>

Now back to your case, I don't think those versions is available for Ubuntu 12.04.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.