1

I am sure this has been asked and answered before but I've looked around and don't see it.

I have a MaaS cluster with two deployable nodes. In addition to the ILO IPMI interface, each box has two network interfaces. I can PXE boot to either one and register the nodes into ready state, and "acquire" them from the cluster controller GUI.

However, when I try to bootstrap Juju, it can never connect to my just-deployed node.

juju bootstrap --to=North.maas 
Bootstrapping environment "maas"
Starting new instance for initial state server
Launching instance
   - /MAAS/api/1.0/nodes/node-445132b0-08c0-11e5-b473-001b24b3b2f4/
Installing Juju agent on bootstrap instance
Waiting for address
Attempting to connect to North.maas:22
Attempting to connect to North.maas:22
Attempting to connect to 192.168.137.105:22

The reason it hangs is that the 192.168.137.0/24 network is the managed network for the MaaS cluster controller. It is not routable to the network that is running JuJu (192.168.1.0/24). The node that is deployed doesn't seem to launch the non-MaaS network either - the one that goes to the JuJu control node. I have tried swapping eth0 and eth1 for the two networks and the end result is the same.

What am I missing?

UPDATE 3 June 2015

Once the node is deployed from the bootstrap, I can ssh to the node from the cluster controller, and manually edit /etc/network/interfaces, bring up eth0 with DHCP managed by my router, delete the existing default route to the MaaS network, and add a new default route to the main network - and I have bidirectional access - from the node to the internet, and from my JuJu host to the IP address on the eth0 network that it got from my router. It's really unclear to me why this wasn't configured by MaaS as the node was brought up.

16:41 I have verified that if I bring up eth0 manually with dhcp in /etc/network/interfaces:

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
auto eth0                               # <--- added
iface eth0 inet dhcp                    # <--- added

# Primary interface (defining the default route)
iface eth1 inet manual

# Bridge to use for LXC/KVM containers
auto juju-br0
iface juju-br0 inet dhcp
    bridge_ports eth1

then restart the avahi-daemon, then the JuJu node (a mac) can get to the North node with

ssh ubuntu@North.local

The hostname is simply "North", which is why this works. North.maas isn't going to work, even if MaaS/Juju had configured eth0. The /etc/hosts file has in it:

127.0.1.1       North.maas      North

I have to be missing something fundamental in node naming and network settings on MaaS.

  • It sounds like the problem is that you are getting the wrong IP address for North from your DNS (MaaS?) server, or, alternately, you have different DNS servers on each network, and you have the x.x.137.0 DNS server as higher priority, so it responds with that address. That is not to say I know how to fix it, but here is a Q/A that might give you some info: askubuntu.com/questions/63160/… – rmustakos Jun 3 '15 at 21:38
  • Thanks rmustakos. I think you're right that it isn't getting the right IP address. What should happen, I think, is that the node uses mDNS to advertise its IP address on both networks. SInce it's not bringing up the x.x.1.0 network, the DNS lookup fails by name so it tries the only IP address it knows, and that isn't routable to JuJu. FYI I do indeed have a DNS server on each network, by design. The MaaS server manages the x.x.137.0 network - for DHCP, DNS and PXE boot. It can't interfere with the x.x.1.0 network which has its own DHCP server. – jpa57 Jun 3 '15 at 23:09
  • Oops - I meant DHCP server on each network. DNS should be by way of mDNS.... I think. – jpa57 Jun 3 '15 at 23:16
2

This is only a partial answer. I noticed the following message under the Fully Qualified Domain Name dialog box for the nodes:

The FQDN (Fully Qualified Domain Name) is derived from the host name: If the cluster controller for this node is managing DNS then the domain part in the host name (if any) is replaced by the domain defined on the cluster; if the cluster controller does not manage DNS, then the host name as entered will be the FQDN.

I entered North.local here and turned off DNS for the managed network x.x.137.0. The bootstrap still didn't bring up eth0, but when I did that manually the JuJu bootstrap continued.

So the remaining mystery is why didn't MaaS configure the interface.

  • Yes. I have also wondered why MaaS does not configure the second nic. – rmustakos Jun 4 '15 at 22:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.