0

I was following this guide: http://developer.ubuntu.com/en/start/ubuntu-for-devices/porting-new-device/

and when I got to the step:

Then, install all the other packages you will need for the build by running this command:

sudo apt-get install git gnupg flex bison gperf build-essential \
  zip bzr curl libc6-dev libncurses5-dev:i386 x11proto-core-dev \
  libx11-dev:i386 libreadline6-dev:i386 libgl1-mesa-glx:i386 \
  libgl1-mesa-dev g++-multilib mingw32 tofrodos \
  python-markdown libxml2-utils xsltproc zlib1g-dev:i386 schedtool \
  g++-4.8-multilib

apt said:

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libgl1-mesa-glx:i386 : Depends: libglapi-mesa:i386 (= 10.1.3-0ubuntu0.4)
                    Recommends: libgl1-mesa-dri:i386 (>= 7.2)
 unity-control-center : Depends: libcheese-gtk23 (>= 3.4.0) but it is not          going to be installed
                    Depends: libcheese7 (>= 3.0.1) but it is not going to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

How can I fix this? Let me know if more information is needed.

EDIT:

using aptitude the solution is:

The following actions will resolve these dependencies:

  Keep the following packages at their current version:          
1)      binutils:i386 [Not Installed]                                
2)      cpp:i386 [Not Installed]                                     
3)      cpp-4.8:i386 [Not Installed]                                 
4)      gcc:i386 [Not Installed]                                     
5)      gcc-4.8:i386 [Not Installed]                                 
6)      libgl1-mesa-dri:i386 [Not Installed]                         
7)      libgl1-mesa-glx:i386 [Not Installed]                         
8)      libglapi-mesa:i386 [Not Installed]                           

  Leave the following dependencies unresolved:                   
9)      libc6-dev:i386 recommends gcc:i386 | c-compiler:i386         
10)     libgl1-mesa-glx:i386 recommends libgl1-mesa-dri:i386 (>= 7.2)

This solution leaves essentially 1 unresolved dependancy, and the dependancy is a recommendation:

 Leave the following dependencies unresolved:                   
4)     libgl1-mesa-glx:i386 recommends libgl1-mesa-dri:i386 (>= 7.2)
  • Try installing gcc and build-essential first – su do Jun 3 '15 at 2:48
  • Both are currently installed, and the command still has the same return values. – Trey Gordon Jun 3 '15 at 2:51
  • And what happens if you say 'n' to the solution? – su do Jun 3 '15 at 3:02
  • apt generates no solution and returns to prompt, the aptitude solution was finished with Yes, leaving the noted dependencies apparently unresolved. – Trey Gordon Jun 3 '15 at 3:24
  • This problem is essentially solved, thanks for the solution @su – Trey Gordon Jun 3 '15 at 3:31
2

You can try using aptitude. It has better dependency handling as far as I know.

Otherwise install the required packages before using that apt-get line.

sudo apt-get install libglapi-mesa libcheese-gtk23 libcheese7 libgl1-mesa-dri
  • aptitude at least fetches the packages, thank you for the assistance, how may I prevent this from happening in the future? I have a few redundancies in my repository lists from some other guide on the touch development. – Trey Gordon Jun 3 '15 at 2:00

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.