I have got a wireless connection to the internet. I have got two operating systems, one of them is Ubuntu 14.04 and the other one is Windows 7. My problem is, the downloading speed of the Ubuntu is much slower than the downloading speed of the my Windows OS. I can download 5 times faster with Internet Download Manager on windows than downloading the same file with FatRat, FlashGot, SteadyFlow, Axel, Uget, and even Wget on Ubuntu. It seems that the Ubuntu downloading speed is too slow. The same thing does NOT hold for loading web pages.
The other problem is, whenever I try to download something with ubuntu I get two options, one would be to download the file via one of the external programs that I have installed like Axel which would be gone through it via FlashGot on Firefox. Is not there any way to make the program like Axel or SteadyFlow to popup automatically whenever I click a download link? Just like internet download manager.

  • 1
    Same problem with a wired connection? Jun 2, 2015 at 20:56
  • @davidbaumann Yes, nothing changes when I use the wired connection. However, if there is any configuration which can make the download speed faster I would be happy to hearing it.
    – FreeMind
    Jun 3, 2015 at 12:16

2 Answers 2


You need to do more in these applications than IDM, for example in IDM they try to use as many connections as possible (this can actually get you banned from some servers) whereas uGet default is to use 1. Edit your settings for uGet to use more connections for the file you are trying to download.

As for the auto-load thing, sure. FlashGot add-on for Firefox can do this.

For example set the default option in FlashGot to be uGet and then download something. The popup that asks to complete download also has a check box to remember that setting, check that and the next time it will auto-load uGet.


You need to setup repositories from where you can download software in maximum bandwidth. Here is how:

Unity(DASH_board) > software and updates > Ubuntu Software > Download From > Other > Choose Best Server > OK > OK.

Reload cache and try again downloading software.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .