Since the last update of my nvidia drivers on Ubuntu (15.04, 64 bit), I get a black screen when logged in Ubuntu.

A second monitor does not help.

Choosing the recovery mode on Grub doesn't help because:

  1. Choosing different options on failesafeX does not change anything.

  2. Choosing the dpkg option doesn't repair anything.

  3. Going to the root shell prompt is useless: I can't use apt-get install or purge because the administration directory is locked.

I don't have a DVD of 15.04 and I don't want to reinstall everything. What are my options?

2 Answers 2


Reboot your machine and press and hold SHIFT until Grub menu shows up. Select the second option Enhanced Options for Ubuntu and then second option ... (recovery mode) again.

In Recovery Menu choose root and type mount -o remount,rw / to remount the filesystem with read AND write permissions.

Now you can proceed purging the nvidia drivers. Run dpkg -l | grep nvidia | grep -v nvidia-common to see a list of all packages. Run `apt-get remove --purge ' with all the packages from above.

  • I'll try your solution. Just one question: is it mount -o remount,rw / or mount -o remount, rw / Jun 3, 2015 at 12:13
  • @su I combined your solutions and it worked. I purged the nvidia drivers (except nvidia-common) and installed xserver-xorg-video-nouveau. But now, I can't access parameters -> display and I cannot configure the second monitor. Jun 3, 2015 at 14:38
  • You can either give mount options in a comma separated list (w/o space) -o remount,rw or each with its own -o like -o remount -o rw
    – Germar
    Jun 3, 2015 at 15:20

Ctrl + Alt + F3 to a shell before logging in. Login on the shell and update/upgrade.

answer #1 if it doesn't work

If it's still not working, sudo rm /var/lib/dpkg/lock should allow apt-get to return to normal use.

Once that is sorted, try purging the nvidia drivers and install xserver-xorg-video-nouveau. How can I uninstall a nvidia driver completely ?

  • I can't test your solutions. I tried ˋCtrl + Alt + F3ˋ before and after entering the sda3-crypt password but couldn't access a consol. By the way, when I manage (by luck) to get to the normal Ubuntu login screen, Ubuntu keeps asking my session password. Jun 2, 2015 at 20:46
  • I didn't realize you were stuck on the encryption part. I had a similar issue where the encryption screen was blank or inclomplete. Entering the password, pressing enter, and going to shell(blinking cursor) like above and then back "refreshed" the screen so to speak and I got to the ubuntu login.
    – su do
    Jun 2, 2015 at 21:38

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .