I have an asus5431 laptop with a built in webcam. This is detected and works fine in Cheese and everyother application. (/dev/video0)

I also have a Quickcam e3500 which is detected by Ubuntu, appears to be loaded as /dev/video1. Only problem is that there is no video. I can use the inbuilt microphone and change the LED status with gstreamerproperties ( i cam make it flash at whatever frequency i like :)) . but no video

I know the camera works since in Mac OS and Windows it is fine.

I do not need the in-built camera since the laptop is under the sofa.

Any ideas anyone?


As you stated in your question:

This problem was caused by my USB hub. I tried the camera without the hub and all worked fine. I can still crash the webcam/v4l2 sometimes but a reboot clears that. Annoying but at least I know that the camera works


first thanks to Sergey for the good idea to test our cams, it's simple and works fine!! :D

I have resolved my problem installing the package "v4l2ucp", that give to us an interface to control webcam parameters as brightness, saturation, gain and exposure.

I have modified my parameters and now it works, with both cheese and skype..


Are you sure there is really no video? Can it be that the video is very-very dark? My webcam (Logitec E2500) has a problem with brightness - supposedly there's some problem with its driver and it's auto-changing the brightness to its lowest setting. I found no good solution to this though I don't need my webcam too often.

Try directing some bright light source (a flashlight) directly into the webcam and see if there is something on the screen.


This seems to be such a common issue when attempting to use the webcam, usb based, for a video conference through a flash player based system, such as Fonomo, Ubiqq, or Skype, etc.

I suggest you to take a look at the answers provided in these questions, which may lead to help you to fix this issue.

  1. https://askubuntu.com/questions/53495/flash-crashes-on-enabling-webcam/53615#53615
  2. Webcam not detected by Flash
  3. logitec webcam for notebooks deluxe
  4. QuickCam E 3500 working from Cheese, but not Skype

In my case I fixed that issue by using the Flashcam Project, mentioned on these answers and whose instructions for a correct usage can be reached right here: http://www.swift-tools.net/Flashcam/

Another good trick that makes my days when attempting to use the webcam through web browsers is the usage of Webcam Studio, which can be reached here: http://www.ws4gl.org/. After running the Webcam Studio you will have a virtual "bridge" between your physical webcam and what the Flash Player is expecting to find.

I hope this gives you a clue on where to begin.

Good luck!

  • 1. Skype's video is not flash-based; 2. I can't see OP mentioning the webcam doesn't work with Flash only - it looks like there's no video anywhere, including Cheese. The word "flash" in his message refers to "quickly turning on and off", not to the software product :) – Sergey Sep 27 '11 at 0:10
  • Thank you @Sergey, very illustrative your comment. BTW: I see the question clearly reads "This is detected and works fine in Cheese and everyother application. (/dev/video0)" unless you are talking of a different question. And I yet find my answers useful to find a way for a solution. Unless you drop me another of your interesting "reviews", then I will delete it. Thank you very much for your interest on my errors. Additionally: Feel free to edit it if you think it's needed. – Geppettvs D'Constanzo Sep 27 '11 at 0:16
  • Re-read this: "...built in webcam ... is detected and works fine in Cheese and every other application", "I also have a Quickcam e3500 which is detected by Ubuntu, [but] there is no video". I agree that your answer may be useful for OP though possibly indirectly. – Sergey Sep 27 '11 at 0:40
  • How does this lead us to find a solution? Have a nice day @Sergey. – Geppettvs D'Constanzo Sep 28 '11 at 16:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.