2

All the current guides on setting the resolution at login are outdated. Most of them suggest using an xrandr command in /etc/gdm/init/default. Problem is, it doesn't seem to work in 15.04 because init.d was replaced with systemd, finally.

has anyone figured how to force the resolution at login? My default resolution results in a black screen, so I have to login blind.

3

The secret is monitors.xml, simply copying your user configuration to the root will fix the issue. Assuming you configure your resolutions with the Gnome Settings Panel, as that will update monitors.xml, while xrandr cli will not.

sudo cp .config/monitors.xml /var/lib/gdm/.config/

http://old-blog.markladoux.com/2013/10/03/fixing-screen-resolution-for-gnome-and-gdm-on-fc19/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.