18

I just got this error from Kubuntu 15.x when starting up after restart to upgrade kernel.

Error getting authority: Error initializing authority: Could not connect: No such file or directory (g-io-error-quark, 1)

PS. Please note this is not a duplicate of: 'starting version 219' bug after the 15.04 update while the error message is similar, the root cause is different (which is example of terrible design if you ask me).

33

The reason for this error was entry in /etc/fstab that pointed to partition UUID that was no longer existing (after i reformated one of the hard drives).

The solution was to remove the fstab entry.

NOTHING AT ALL in the error message indicates what might be the cause of the error, neither does calling journalctl as systemd suggest.

Browsing the internet revealed that the exact same error can be produced in several different situations. Take a look at 'starting version 219' bug after the 15.04 update for other causes. Googling for the phrase returns few other possible causes.

Hope it helps anyone who stumbles upon this cryptic error.

  • 2
    I also encountered this with Fedora 22. – John Schmitt Aug 20 '15 at 21:34
  • 1
    Thank you for the info, got it from dual boot windows 10 (reboot) and Ubuntu 15.10 – TungstenX Jan 8 '16 at 11:34
  • 2
    Just wanted to add my two cents, that it can be caused by not shutting down Windows 8, 8.1 or 10 without the new fast-boot feature. – MaverickMartyn Feb 24 '16 at 12:43
  • Got this when a Windows 10 update on my dual boot box set windows to use "fast boot" and therefore to some kind of a lock on a shared NTFS drive - systemd interpreted that as the drive being in an 'unclean state' and wouldn't boot it until I'd disabled the setting in Windows. Adding 'nofail' in fstab might help, but I'd rather err on the side of caution and get windows to properly unmount/unlock the volume for writes on shutdown! – nikobelia Apr 16 '17 at 20:14
12

One of your mount points is failing. View the log to see which one.

journalctl -xb

Search the log for the word mount by typing /mount Enter and n to find the next entry. You'll eventually see an error in the log. Take note of the mount point.

Edit /etc/fstab with your favourite text editor.

vim /etc/fstab

Add the option nofail to the failing mount point or all the mount points that are not required at boot time.

# <file system>                           <mount point>         <type> <options>            <dump><pass>

UUID=005c216a-012e-440c-8e92-c955cbc48c34 /mnt/notrequired      btrfs  rw,noatime,nofail    0     1

Reboot

systemctl reboot
7

It's worth stressing that any failed fstab mount will cause full system failure with the meaningless error message. That includes cd, dvd, swap, mapper and data partitions. Put the nofail option on to every line in /etc/fstab that you think might not be available at any boot time, even apparently otherwise unimportant ones.

Unfortunately some bad decisions were made with systemd including a lack of fault tolerance and a lack of actionable error messages. It's not at all clear that the advantages of systemd outweigh the disadvantages.

1

I solved this problem by restarting my computer, entering recovery mode and using "clean". Hope this helps somebody.

  • This was the only solution that worked for me, since ubuntu was failing to mount my /home partition – Jonathan May 23 '17 at 4:29

protected by Community Jul 24 '18 at 12:48

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.