1

Ok, don't judge this as a duplicate question, please read through the whole thing.

I have read the other thread and the solution is usually to press Ctrl+Alt+F1 and then start working on the problem. Read my problem and you will see that solution does not fit me.

This is my problem: Somewhere during installation of Nvidia Drivers (or afterwards), I restarted the PC and now I can not login to the system anymore.

Everything boots up as normal until I am prompted with the Ubuntu login page. I enter my password, the screen gets black and soon after that the login screen comes back. Now to the much bigger problem, I can not even use Ctrl+Alt+F1 (to F6) to get a tty console. Pressing Ctrl+Alt+F1 just takes me to a black screen and nothing happens, the only combination which works in Ctrl+Alt+F7 which takes me back to the login screen.

I can use the guest user to enter the system but I have no access privileges to do anything useful there and I still get the same issue if I press Ctrl+Alt+F1.

What can I do at this point? (I spent hours setting up that system)

1

Follow instructions bellow
1- Use a live Linux cd and chroot to your Ubuntu.
2- Remove nvidia driver using apt-get purge.(apt-get purge nvidia-*)
3- Reinstall ubuntu-desktop package.

  • tried this. did not help. – theAlse Jun 2 '15 at 11:23
  • try reconfigure lightdm using dpkg-reconfigure lightdm – M.Fooladgar Jun 2 '15 at 11:45
  • And you can try using modprobe nouveau, maybe it works. – M.Fooladgar Jun 2 '15 at 11:49
0

I had that problem in my PC,I tried everything. (delete xauthority and ICEauthority files, restart lightm, reconfigure lightdm..). Nothing works.

so, I suggest you to refresh your ubuntu. I think that's the only solution for login loop...

0

I just has this issue. What worked for me was doing the ALT+CTRL+F3 and in there, ,log in, and re-install ubuntu-desktop package.

Not sure what it did.. But it worked.

0

Are you able to get into the grub2 menu? Have you tried safe mode

How would I boot into the Ubuntu and Windows recovery modes if I removed the options to do so from the Grub menu?

I just read your edit after I gave the answer, your ability to use the guest login points to an error with your account / password / privileges did you use an old /home directory or an old /etc/passwd file?

Not being able to use terminals 1-6 could be graphic related (wrong mode) Did you read the Messages behind the splash-screen (ESC). Are you as a guest privileged enough to read /var/log ?

0

I went into recovery mode (in gnub on advanced options), enabled network, went into root shell and installed gdm.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.