1

This question already has an answer here:

If we select default wallpapers in Ubuntu as desktop background image it will automatically set the same image as login screen. But if we use a custom image as a wallpaper it will only change the desktop background but the login screnn will change to a default wallpaper. Why this is happening and how can we set a custom image as background for both desktop and login screen

enter image description here

marked as duplicate by Mitch Jun 2 '15 at 5:58

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

2

A simple trick copy that pic to the background folder

sudo cp somepic.jpg /usr/share/backgrounds/

Now the perfect solution:

  1. Make sure your wallpaper is readable by lightdm

    chmod 644 somepic.jpg
    
  2. Run this command:

    gsettings set com.canonical.unity-greeter draw-user-backgrounds true.
    

    This to enable unity-greeter background drawing if it's not

  3. Run this command:

    gsettings set org.gnome.settings-daemon.plugins.background active true
    
  • copied my picture file to /usr/share/backgrounds/ , changed file permission and run gsettings command but still not working – Eka Jun 2 '15 at 8:30
  • Install ubuntu tweak and try from there. you can there indicate which to background and which to put as login wallpaper – Maythux Jun 2 '15 at 8:32

Not the answer you're looking for? Browse other questions tagged or ask your own question.