1

I have a Windows 8.1 desktop machine with a 27" QHD monitor. Under Control Panel\Appearance and Personalization\Display, I have set "Change the size of all items" to medium (recommended) so I can comfortably read the font on my QHD screen.

I then want to remote desktop from my linux notebook with a 15" FHD screen, so I set the remote desktop resolution to 1920x1080 in Remmina and connect to the server. The problem is the font and titlebars are huge. If I go into the display settings in my remote desktop session, the "Change the size of all items" setting is on the lowest (Smallest) setting and is grayed out regardless. I can click on "Let me choose one scaling level for all my displays and set the scaling to 100%. After logging out and back into my remote desktop session the font and title bars are all scaled nicely to a usable size, which is great! Then I log back into my desktop machine directly and the font is minuscule, so I need to increase the scaling settings on my desktop again.

I have tried searching for other people with the same problem and my search terms are either bad or no one else has the same problem or setup, which I find hard to believe.

I would really like to find a good fix so I don't need to use a clumsy workaround of changing the DPI every time I log in from a different machine.

0

gconf-editor should allow you to set adjust the font DPI, effectively scaling it dynamically. See this answer

gconf-editor

  • I'm not really sure that this is the answer. The font dpi is fine in my native gnome session. I just need it adjusted in my remote desktop session. – mrpringle Jun 9 '15 at 5:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.