2

My WiFi doesn't work on my newest Lenovo T450s. By doesn't work, I mean sometimes it will work, and then for some reason it'll stop. It'll even break the router if I insist too much on reconnecting.

I have read everything and seen every post on the topic.

Here's what I have:

$ uname -r
3.16.0-38-generic

~$ sudo lshw -C network
  *-network               
       description: Ethernet interface
       product: Ethernet Connection (3) I218-LM
       vendor: Intel Corporation
       physical id: 19
       bus info: pci@0000:00:19.0
       logical name: eth0
       version: 03
       serial: 68:f7:28:8a:e2:b6
       capacity: 1Gbit/s
       width: 32 bits
       clock: 33MHz
       capabilities: pm msi bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=e1000e driverversion=2.3.2-k firmware=0.2-3 latency=0 link=no multicast=yes port=twisted pair
       resources: irq:61 memory:e1200000-e121ffff memory:e123e000-e123efff ioport:4080(size=32)
  *-network
       description: Ethernet interface
       product: RTL8192EE PCIe Wireless Network Adapter
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:03:00.0
       logical name: wlan0
       version: 00
       serial: ac:e0:10:0f:4f:87
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical
       configuration: broadcast=yes driver=rtl8192ee driverversion=3.16.0-38-generic firmware=N/A ip=192.168.1.14 latency=0 link=yes multicast=yes
       resources: irq:64 ioport:3000(size=256) memory:e1000000-e1003fff

which if I'm correct, means the driver used is rtl8192ee 3.16.0-38-generic.

Thing is, I'm using Ubuntu 14.04. I have read several times that there were unstabilities with the newest drivers. So I tried to downgrade/backport to an older kernel version. Without success: I keep seeing 3.16.0-* in the grub menu.

I also tried to disable N, or other encryption options, on several drivers, without success.

0

Just install this driver

sudo apt-get install git build-essential
git clone https://github.com/lwfinger/rtlwifi_new.git
cd rtlwifi-new
make
sudo make install

But you will have to re-install it after each kernel upgrade.

4
  • Installation went fine, I rebooted, but the rtlwifi doesn't seem to be used: sudo lshw -C network | grep driver: configuration: broadcast=yes driver=rtl8192ee driverversion=3.16.0-38-generic firmware=N/A ip=192.168.1.14 latency=0 link=yes multicast=yes. Did I miss something? – Cécile Cazals Jun 1 '15 at 21:34
  • It is used. Rtlwifi is a number of drivers, rtl8192ee is one of them. It just replaced the original one. This is a newer version from Relatek engineers. It should work much better. – Pilot6 Jun 1 '15 at 21:36
  • I wish but it doesn't... – Cécile Cazals Jun 1 '15 at 21:39
  • Do you have Windows? Does it work better? It can be a hardware problem, like bad contact in antenna. Anyway it is the best driver for this chip for now. – Pilot6 Jun 1 '15 at 21:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.