1

Summary:

When trying to install Ubuntu i get

Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(2,0)

and the other questions adressing the same error doesn't help since all of them requires me to do things from within ubuntu or to boot ubuntu in recovery mode but I don't have ubuntu installed so I can't do that.

Long version:

I have had Uberstudent (based on Ubuntu) working for a week on my Acer 720p Chromebook. Then I ran a script to fix the touchpad(which usually doesn't work properly at first with this type of laptop).

After rebooting after running this script the laptop couldn't find wifi and sudo commands didn't work(it just loaded forever. I tried things like "sudo echo "hello""). So I decided to reinstall the OS. So I reinstalled Chrome OS and did a "powerwash".

When repeating the exact process(using LiveUSB with UNetbootin) I did last week it didn't work. After choosing the "Start Uberstudent" option from the blue UNetbootin-menu it stopped and displayed the error:

Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(2,0)

I have tried switching usb and I tried installing Ubuntu instead. Both with the same result.

There are other similar questions on this site. The difference is that all of those were solved by booting into Ubuntu and doing things from there. But I don't have anything else but Chrome OS installed so they don't apply to my situation.

The script I used to fix my touchpad was cros-haswell-modules.sh modified by using

# Grab Ubuntu kernel source
wget https://www.kernel.org/pub/linux/kernel/v3.x/linux-3.12.5.tar.xz
tar -xJf linux-3.12.5.tar.xz
cd linux-3.12.5

instead of

# Grab Ubuntu kernel source
apt-get source linux-image-$mykern
cd $mykernver

as instructed by this site. But i feel that this shouldn't matter since I uninstalled the OS and did a powerwash from Chrome OS.

Someone told me that it could be that the SSD isn't functioning but I bought it a week ago and I have been careful with my laptop. And the rest of the laptop should be working fine too since I bought it two weeks ago.

Anyone here knows how to fix this kernel panic when i don't already have Ubuntu installed?

Any help is appreciated

4

Last week I installed Ubuntu on my desktop and got the same error. I thought it was my SSD but it appeared to be the USB with Ubuntu on it.

I formatted the USB drive on my other Windows PC and downloaded Ubuntu again. Then created a bootable drive with Rufus https://rufus.akeo.ie/ which also let's you check for bad blocks on the stick.

After that I tried installing again and it worked.

0

Problem is a file system of USB drive. Downloading another copy of Ubuntu is not necessary, just start Rufus and format disk as fat32. Worked for me.

  • Your answer is very short and seems to assume a lot. Also not everyone might now what 'Rufus' is. – Minos Nov 19 '15 at 11:09
  • Sorry, I can not make comments and I was trying to add something to Thom Mekelenkamp answer. He's answer did the trick. But the problem wasn't in corrupted ISO or something with USB drive it was simply wrong file system type. – Spicko Nov 19 '15 at 12:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.