1

I want to install libpcre3-dev:386 onto 64-bit Ubuntu 14.04.

I have libpcre3:i386 installed, as well as the :x64 -dev version. But if I run 'sudo apt-get install libpcre3-dev:i386', apt wants to remove "all" of my build tools:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
...
The following extra packages will be installed:
  libc6-dev:i386 libpcrecpp0:i386 linux-libc-dev:i386
Suggested packages:
  glibc-doc:i386 manpages-dev:i386
Recommended packages:
  gcc:i386 c-compiler:i386
The following packages will be REMOVED:
  build-essential camlp4 dkms dpkg-dev g++ g++-4.7 g++-4.7-multilib g++-4.9
  g++-4.9-multilib gcc gcc-4.7 gcc-4.7-multilib gcc-4.9 gcc-4.9-multilib
  gcc-multilib hardening-includes lcov libtool lintian ocaml
  ocaml-compiler-libs ocaml-interp ocaml-nox pepperflashplugin-nonfree
  sa-compile virtualbox-dkms
The following NEW packages will be installed:
  libc6-dev:i386 libpcre3-dev:i386 libpcrecpp0:i386 linux-libc-dev:i386
0 upgraded, 4 newly installed, 26 to remove and 11 not upgraded.

Any idea what it's doing and/or how I can get it to install the 32-bit -dev library?


Disclaimer: I installed GCC 4.9 from a PPA (ppa:ubuntu-toolchain-r/test). After installing, I removed it as a repository; if I re-add it, then gcc-4.9 and its associated packages disappear from the list of things that will be removed:

The following packages will be REMOVED:
  build-essential camlp4 dkms dpkg-dev g++ g++-4.7 g++-4.7-multilib gcc
  gcc-4.7 gcc-4.7-multilib gcc-4.8 gcc-4.8-multilib gcc-multilib
  hardening-includes lcov lintian ocaml ocaml-compiler-libs ocaml-interp
  ocaml-nox pepperflashplugin-nonfree sa-compile virtualbox-dkms
The following NEW packages will be installed:
  gcc-5-base gcc-5-base:i386 libc6-dev:i386 libpcre3-dev:i386 libpcrecpp0:i386
  linux-libc-dev:i386

I see GCC 5 in that list. Is that causing the problem somehow? I'll leave it enabled for everything else here.


If I download the .deb for libpcre3-dev directly and try to install it with dpkg -i, it says:

dpkg: dependency problems prevent configuration of libpcre3-dev:i386:
 libpcre3-dev:i386 depends on libc6-dev.
 libpcre3-dev:i386 depends on libpcrecpp0 (= 1:8.31-2ubuntu2).

Earlier, I tried installing libc6-dev:i386 but it gave me the same list of packages that would be removed.

Also, now if I try to run apt-get again, it complains

You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 libpcre3-dev:i386 : Depends: libc6-dev:i386 but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

and if I try to run apt-get -f install, it gives me the same list of packages to remove.

(Incidentally, I've obviated the need for actually installing this for now, by manually unpacking the .deb file in a different location. So now advice for getting apt back into a happy state is more important, though I would still like to know what was going wrong originally.)

  • Possibly something from that ppa. On 14.04 here it would install cleanly, adding 7 packages - gcc-4.8-base:i386 libc6-dev:i386 libpcre3:i386 libpcre3-dev:i386 libpcrecpp0:i386 libstdc++6:i386 linux-libc-dev:i386, what's your current gcc-4.8-base package? – doug Jun 1 '15 at 20:31
  • I am editing more info into the question, including PPA name. 'dpkg -s gcc-4.8-base' shows 'Architecture: amd64, Multi-Arch: same, Version: 4.8.2-19ubuntu1'. Is that what you want? – EvanED Jun 1 '15 at 20:59
  • Well adding that ppa doesn't really hurt here, just adds a few - The following extra packages will be installed: gcc-5-base gcc-5-base:i386 libc6-dev:i386 libpcre3:i386 libpcrecpp0:i386 libstdc++6 libstdc++6:i386 linux-libc-dev:i386 The following packages will be upgraded: libstdc++6 Did you happen to use trusty -proposed before then disable? (it's not enabled now. – doug Jun 1 '15 at 21:24
-1

See this StackOverflow post. It's trying to purge your package (and dependencies) and redownload it all back. Instead, try running sudo apt-get install --reinstall libc6-dev-i386

| improve this answer | |
  • I tried running that. It did seem to do something ("Preparing to unpack...", "Unpacking...", "Setting up...") but it didn't do anything to help the main problem. – EvanED Jun 1 '15 at 20:02
  • What makes you think that the issues are related? – heemayl Jun 1 '15 at 21:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.