1

I have been a user of KeePass for a long time. Until a few years back, I had only one desktop, and KeePass seems to take care of my password management very well. Now I use multiple devices. What I did was that I stored all my passwords using KeePass on my Android phone and typed them in. But this method is very bad because I started using the same weak password for all my online accounts.

Today morning, I thought of fixing this. I uninstalled KeePassDroid and intsalled keepass2andorid on my phone. I set it up to sync passwords to my Google Drive. I installed keeepass2 on my Ubuntu laptop.

But I can't seem to set up KPGoogleSync plug in. The error occurs when I try to extract the downloaded plugin archive. When I use Archive Manager, it says:

An error occurred while loading the archive.

I tried unzip command and it says:

Archive:  Downloads/GoogleSyncPlugin-2.1.0.zip
  End-of-central-directory signature not found.  Either this file is not
  a zipfile, or it constitutes one disk of a multi-part archive.  In the
  latter case the central directory and zipfile comment will be found on
  the last disk(s) of this archive.
unzip:  cannot find zipfile directory in one of Downloads/GoogleSyncPlugin-2.1.0.zip or
        Downloads/GoogleSyncPlugin-2.1.0.zip.zip, and cannot find Downloads/GoogleSyncPlugin-2.1.0.zip.ZIP, period.

A corrupt archive? Check this out. Strange enough, some people could extract while others can't.

1

Apparently the file was really corrupted on some content servers or there was no way investigate further. Statement from the author:

Uploaded a new version 2.1.1.

Included a checksum as well this time GoogleSyncPlugin-2.1.1. If the file gets corrupted again, I can at least contact SourceForge for an explanation.

2015-06-16 by Danyal in thread Download zip corrupt?

  • could you get it working? – daltonfury42 Jul 13 '15 at 8:58
  • I was able to extract version 2.1.1 on Ubuntu, yes. I did not test it's functionality. – LiveWireBT Jul 13 '15 at 9:06
  • Please tell me if you could do it without using libraries from untrusted sources(the readme provides a link to a forum post telling how to install on linux, but the page to the library which he says need to be installed doesnot have a valid certificate). – daltonfury42 Jul 13 '15 at 9:09
  • 1
    @daltonfury42 I just looked at the readme file and found this link. It's not clear to me about which site mentioned in this you are talking about and it doesn't look like this plugin is easy to setup on a non-Windows OS. I just tried to answer your initial question regarding the corrupted file. – LiveWireBT Jul 13 '15 at 9:31
  • OK, in the link, the poster ask you to download a dll from a site with an invalid certificate. Just add that warning in your answer. – daltonfury42 Jul 13 '15 at 11:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.