2

I'm trying to mount a remote drive on a server that I have SSH access to using fuse/sshfs

I created a mount point at /mnt/review/server and created the following entry in my fstab, as per ArchWiki:

me@server:/    /mnt/review/dori    fuse.sshfs    defaults,user,noauto,idmap=user,allow_other 0 0

I've also tried a slightly different entry, based on the Ubuntu documentation:

sshfs#me@server:/    /mnt/review/dori    fuse    defaults,user,noauto,idmap=user,allow_other 0 0

Each time, I just get /bin/sh: 1: sshfs: not found - nothing in the system logs.

This did work back when I was running Kubuntu 14.04 - I've since changed to Mint running on Ubuntu 14.04, and now I get this.

It seems like SSHFS is not installed - but I can't find anything helpful on Google for this message. I've also made sure the the fuse package is installed. I'm stuck for how to resolve this.

  • Are you using OpenSSH or an alternative like Dropbear? – camconn Jun 1 '15 at 0:21
  • openssh - never used anything else – HorusKol Jun 1 '15 at 1:04
3

You need to install sshfs before you go further.

sudo apt-get install sshfs

Now, you should test that everything is working correctly. You should try mounting your server with.

sshfs -o idmap=user $me@server:/ /mnt/review/dori

If that works, unmount the directory with

fusermount -u /mnt/review/dori

The use the second line you posted about from /etc/fstab.

sshfs#me@server:/    /mnt/review/dori    fuse    defaults,user,noauto,idmap=user,allow_other 0 0
  • d'oh - could have sworn I'd checked that package was installed - thanks – HorusKol Jun 1 '15 at 2:19
1

Since you said sshfs wasn't installed yet, have you tried installing it?

  1. sudo apt-get update
  2. sudo apt-get install sshfs

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.