0

I have installed Gnome 3.16 on my Ubuntu 15.04 (previously updated from 14.04) via:

sudo add-apt-repository ppa:gnome3-team/gnome3
sudo add-apt-repository ppa:gnome3-team/gnome3-staging
sudo apt-get install gnome

However, I am unable to log into the Gnome desktop:

  • If I select gdm as my default desktop manager, my system boots to a black screen only showing the cursor. I can switch into tty, but no other X component loads.
  • If I leave lightdm selected, I am able to log in to Unity, but if I choose either Gnome or Gnome Classic I get a black screen for a couple of seconds after typing my password, then I'm back at the login screen. Gnome Flashback (both Compiz and Metacity options) works, but they are obviously not what I'm interested in using.

I've tried different suggestions from similar, but older, questions, including:

  • Removing any nvidia-* packages
  • Removing my .Xauthority file
  • Manually stopping gdm then running startx

None of these brought any improvement. The only potentially useful log info I can find is in the rather peculiarly-named /var/log/gdm/(null)-greeter.log:

(WW) xf86CloseConsole: KDSETMODE failed: Input/output error
(WW) xf86CloseConsole: VT_GETMODE failed: Input/output error
(EE) 
Fatal server error:
(EE) xf86CloseConsole: VT_ACTIVATE failed: Input/output error
(EE) 
(EE) 
Please consult the The X.Org Foundation support 
         at http://wiki.x.org
 for help. 
(EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
(EE) 
(EE) 
(EE) Backtrace:
(EE) 0: /usr/bin/X (xorg_backtrace+0x56) [0x7f13a8d92556]
(EE) 1: /usr/bin/X (0x7f13a8bdf000+0x1b7749) [0x7f13a8d96749]
(EE) 2: /lib/x86_64-linux-gnu/libc.so.6 (0x7f13a68a5000+0x352f0) [0x7f13a68da2f0]
(EE) 3: ?? [0x7f13ab7f08c0]
(EE) 
(EE) Segmentation fault at address 0x7f13ab7f08c0
(EE) 
FatalError re-entered, aborting
(EE) Caught signal 11 (Segmentation fault). Server aborting

There is no error message in /var/log/Xorg.0.log.

Has anyone seen this before and do they have any suggestions?

Thank you.

1

I know this isn't an answer but I also have the same problem.

I had to purge the gnome-staging ppa and go back down to 3.14.

File a bug and I will also mark myself as affected.

0

Faced similar issue of login failure but i've managed to fix it by cross-grading from Ubuntu to Ubuntu Gnome. Not sure why, but both Unity and Gnome desktops can't coexists and you'll need to purge Unity desktop in order to fix that issue. This is how I got it to work. YMMV.

Install Gnome 3.14 desktop and purge Unity desktop. Make sure you can login through GDM and Gnome desktop.

$ sudo apt-get install ubuntu-gnome-desktop
$ sudo apt-get purge ubuntu-default-settings
$ sudo apt-get purge ubuntu-desktop
$ sudo apt-get autoremove

Add the Gnome 3.16 PPA.

$ sudo add-apt-repository ppa:gnome3-team/gnome3-staging
$ sudo add-apt-repository ppa:gnome3-team/gnome3

Upgrade to Gnome 3.16.

$ sudo apt-get update
$ sudo apt-get dist-upgrade

Restart GDM either through virtual console (Ctrl+Alt+F1) or rebooting the system.

$ sudo service gdm restart

If the problem still persists, consider rollback to Gnome 3.14, again through virtual console.

$ sudo apt-get install ppa-purge
$ sudo ppa-purge ppa:gnome3-team/gnome3-staging
$ sudo ppa-purge ppa:gnome3-team/gnome3
-1

Had the same problem and resolved by hitting ctrl + f1 to drop to a terminal, then running

sudo apt-get update
sudo apt-get dist-upgrade
  • Thanks for the answer. I tried this, but nothing changed. – Andrei Jun 4 '15 at 8:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.