Ubuntu LTS 14.04 Wifi Drops - Needs Reboot - Qualcomm Atheros QCA9565 / AR9565


I have been facing this issue for last few weeks. I have tried many solutions but seems like no success.

System: Dell Inspiron 3537 Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter (rev 01)

Problem: Wifi will suddenly drop saying You are Now Offline. Then It will try to reconnect, sometime WIFI will be greyed, sometime show no WIFI connections, sometime no Wifi option, will mostly fix on reboot, but will drop again within few minutes or sometime after several minutes... it keeps happening.. In the start when it started to happen, pc will hang and take no input, had to reboot using the power button,.. after clean install that hanging issue has been very rare.

Update: After clean ubuntu install i thought system hanging issue was gone, however as I am using with LAN cable for last few hours, it has been about three times, i have experinced this issue too i.e. my system will just freeze/hang, with no notification, nothing, cannot move cursor, or any input on the keyboard.. only can restart with the power button long press. (REISUB input command also dont not work, it just does not take any input, had to reboot with power button.. )

Fixes I have tried:

I have tried many fixes from the thread, it seemed like solution but after some time error will come back again.. Tried: options ath9k nohwcrypt=1

I have tried even Clean Install, I was happy that it would be resolved, but within an hour it start occuring.

I have also installed backport (it was new for me but i followed along, but after reboot, issue started to happen again) downloaded and installed backports-3.16-1 but no success.

It has been troubling me so much after clean ubuntu install that what could else be tried or fixed as it is impacting my laptop use so much, i have to use LAN wire most of the time to get work done.

Thanks so much for your time and help in this regard!

2 Answers 2


First and foremost, the instructions I present below are not a solution, but a workaround until the issue can be fully identified and resolved!

Create the following script and save it where you normally save your scripts - I saved it as /usr/local/bin/wifiup:

ifconfig ${iface} down
iwconfig ${iface} mode Managed
ifconfig ${iface} up
killall wpa_supplicant
wpa_supplicant -B -Dwext -i ${iface} -c ${HOME}/.wireless-wpa.conf -dd
dhclient ${iface}

Ensure the script is executable:

chmod +x /usr/local/bin/wifiup

In the file ${HOME}/.wireless-wpa.conf, I have the following:


Note: Replace [SSID] and [PSK] with values relevant to your Access Point.

When I notice the link is down, I open a terminal session and run the command:

sudo wifiup

If this does not work for you, instead of rebooting the laptop/desktop, identify the Kernel module used by your device (mine uses iwlwifi):

$ lspci -k | awk '/Network/,/Kernel/{print}'
00:19.0 Ethernet controller [0200]: Intel Corporation 82579LM Gigabit Network Connection [8086:1502] (rev 04)
    Subsystem: Dell Device [1028:053f]
    Kernel driver in use: e1000e
03:00.0 Network controller [0280]: Intel Corporation Centrino Ultimate-N 6300 [8086:422b] (rev 35)
    Subsystem: Intel Corporation Centrino Ultimate-N 6300 3x3 AGN [8086:1121]
    Kernel driver in use: iwlwifi

You can then unload and reload the module using the following command at a terminal session:

sudo modprobe -r iwlwifi
sudo modprobe iwlwifi

Sometimes just unloading and reloading your module will initiate the WiFi reconnection, but in case it does not, run the wifiup as stated earlier!

Please report back whether this works for you as interim solution.

  • Thank you so much for your answer. Sure I will try this and report back soon. Jun 6, 2015 at 10:08
  • I've just edited the answer a bit as I forgot to mention that you'd need to make the wifiup script executable.
    – AnthonyK
    Jun 6, 2015 at 11:38

Ever since Ubuntu upgraded itself on my Acer C720P (Chromebook converted to Linux), my Wifi doesn't reconnect.

It'll show SSIDs... but I've noticed those SSIDs are STALE. If I go from home, to work, they'll still show home. So I realized that Ubuntu isn't scanning anymore.

I have yet to find a proper solution yet. However, as a stopgap, I run

sudo wavemon

and press F3, which forces a scan. Once the scan runs, Ubuntu immediately connects to my local wifi. So it's definitely an issue (on my machine) with not scanning upon re-entering from suspend mode.

*wavemon is a wonderful wireless monitoring tool that is available through apt-get.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .