1

This question already has an answer here:

I've just installed Ubuntu on an HP Pavilion and I'm having difficulty with the wireless driver. Initially, the connection would drop after a couple minutes of connectivity.

I tried several solutions, most of which involved compiling and installing different driver versions. At one point, connectivity was improved but still had issues. I tried the instructions here http://ubuntuforums.org/archive/index.php/t-2219952.html but didn't notice any change.

After a restart, I can no longer connect with wireless. Wired connection is fine. Output of lshw -C network:

   *-network UNCLAIMED     
       description: Network controller
       product: RTL8723BE PCIe Wireless Network Adapter
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:01:00.0
       version: 00
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress cap_list
       configuration: latency=0
       resources: ioport:e000(size=256) memory:fea00000-fea03fff
   *-network
       description: Ethernet interface
       product: RTL8101E/RTL8102E PCI Express Fast Ethernet controller

and the output of lspci -nn | grep 0280 is:

01:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8723BE PCIe Wireless Network Adapter [10ec:b723]

I tried repeating some of the driver installs but nothing changed. I also tried following the various links in this thread: http://ubuntuforums.org/showthread.php?t=2205497 but all the repos with my device version (RTL8723BE) are empty.

I'm new to ubuntu and thought I should ask for help here instead of blindly following any more instructions. Any help would be appreciated.

marked as duplicate by Community May 31 '15 at 17:18

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • yes - that previous solution suggests a repo that is up to date and seems to have solved my issue. @Pilot6: Thanks for your help. – smrkem May 31 '15 at 17:18