How can I mount OS X 10.7 Lion shares on my Ubuntu box (10.10, 11.4)?

Since OS X 10.7 Lion update, network integration with Ubuntu is a nightmare. Previously we could print on OSX printers and mount OSX file shares in a snap, using SMB/CIFS.

Now I got to print on OSX Lion printers using CUPS and IPP sharing... DONE! no samba: it works.

Worst I cannot anymore access files on OS X Lion shares (it was OK up to Snow Leopard).

Exactly from Nautilus I can still browse the OSX server shares, mount one of them (using Nautilus and smb:// URL), I can even browse all the share's directory tree, but whenever I try to open a file (even for read-only)

I receive the error

Impossible to open file <<smb://<host>/<share>/<file-path>> Unexpected error: Function not implemented

(this is Konqueror);

When trying to mount.cifs, it reports to me

root@UL30AL64:/home/fmoli# mount.cifs //<host>/<myshare> /media/gw-fm -o user=<myname>,password=<mypwd>,nounix,noserverino,sec=krb5
mount error(126): Required key not available
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

Rumours in the net tell that SAMBA4 is the recipe for Linux/Ubuntu. But I tried to set-up samba4 without any luck (very lack of guides around...)

Other ones suggest to install netatalk on Ubuntu. But netatalk is a "server-only" package: I need to mount OSX shares on Ubuntu, not Ubuntu shares on OSX !

  • I'm having the same problem in Ubuntu 11.10, can't mount OS X Lion SMB/CIFS shares like before. Mar 14, 2012 at 17:51

3 Answers 3


With reference to this post in Apple discussion community, you can try to mount with additional two options: nounix,sec=ntlmssp

I've tried that, it works properly:

mount.cifs //192.168.0.x/public /mnt/public -o user=myusername,password=mypassword,nounix,sec=ntlmssp,noperm,rw
  • Hi Sengtui,thank you very much for your answer, I tested it and it works, undoubtedly. Still it's as a bit unconfortable, as I have to mount / unmount via CLI, and I cannot do this via Nautilus GUI, nor even use credentials sdtored in keyring.... but it works! Oct 18, 2011 at 12:09
  • Thanks for the solution, though I'm disappointed it means I have to drop to the command line every time I want to mount an SMB/CIFS share on OS X. With the features they've removed and now this, I'm tempted to go back to Snow Leopard. Mar 14, 2012 at 17:53
  • You just saved my mac from being influenced with a sledgehammer. Many thanks.
    – LRE
    Apr 23, 2014 at 10:06
  • What would be a /etc/fstab version of this command? Feb 3, 2015 at 13:02
  • "invalid argument". granted, it's no longer Lion.
    – Michael
    Apr 16, 2020 at 5:24

This solution is more generalized and will let you access files on OS X from Ubuntu 11.10, though now via SMB/CIFS. On OS X Lion, enable Remote Login in Sharing, add your user so that you can access it, and then on Ubuntu 11.10 it should show up in Browse Network accessible as SFTP.


You can use /etc/fstab as well:

//192.168.0.x/public    /mnt/public    cifs    credentials=/root/.credentialsfile,iocharset=utf8,nounix,sec=ntlmssp,noperm,rw

the /root/.credentialsfile would look like:


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .