7

Ubuntu 14.04 Repositories: universe, main

Ran apt-get update

Ran apt-cache policy libssl1.0.0

ddew@ddew-wsl:~$ apt-cache policy libssl1.0.0
libssl1.0.0:
  Installed: 1.0.1f-1ubuntu2.11
  Candidate: 1.0.1f-1ubuntu2.11
  Version table:
 *** 1.0.1f-1ubuntu2.11 0
        100 /var/lib/dpkg/status
     1.0.1f-1ubuntu2 0
        500 http://archive.ubuntu.com/ubuntu/ trusty/main amd64 Packages

Was surprised to see that the version advertised as the candidate is not the same as what is available from main and that the version available from main is older than the version that is already installed.

Attempted to install libssl-dev

ddew@ddew-wsl:~$ sudo apt-get install libssl-dev
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:
The following packages have unmet dependencies:
 libssl-dev : Depends: libssl1.0.0 (= 1.0.1f-1ubuntu2) but 1.0.1f-1ubuntu2.11 is to be installed
              Recommends: libssl-doc but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Out of curiosity, ran apt-cache policy libssl-dev

ddew@ddew-wsl:~$ apt-cache policy libssl-dev
libssl-dev:
  Installed: (none)
  Candidate: 1.0.1f-1ubuntu2
  Version table:
     1.0.1f-1ubuntu2 0
        500 http://archive.ubuntu.com/ubuntu/ trusty/main amd64 Packages 
  • I have two PPAs configured. One is for Chromium. The other is for VirtualBox. I wonder if either of those might have caused the installation of libssl1.0.0 version 1.0.1f-1ubuntu2.11 – Doug Dew May 31 '15 at 1:29
  • Nope. I just checked some installation dates. It seems that libssl1.0.0 was installed before anything from either of those two PPAs was installed. – Doug Dew May 31 '15 at 1:39
  • According to the published package list, both libssl-dev and libssl1.0.0 should be at version 1.0.1f-1ubuntu2.11: – Doug Dew May 31 '15 at 1:41
  • packages.ubuntu.com/… – Doug Dew May 31 '15 at 1:41
  • So, it seems that my local package database for main is not up to date. But, I've run apt-get update. So, I'm not sure what to do next. – Doug Dew May 31 '15 at 1:43
9

Same problem on Ubuntu 16.04

$ apt-cache policy libssl1.0.0    
libssl1.0.0:
  Installed: 1.0.2g-1ubuntu4.5
  Candidate: 1.0.2g-1ubuntu4.5
  Version table:
 *** 1.0.2g-1ubuntu4.5 100
        100 /var/lib/dpkg/status
     1.0.2g-1ubuntu4.1 500
        500 http://mirror.uoregon.edu/ubuntu xenial-updates/main amd64 Packages
        500 http://mirror.uoregon.edu/ubuntu xenial-security/main amd64 Packages
     1.0.2g-1ubuntu4 500
        500 http://mirror.uoregon.edu/ubuntu xenial/main amd64 Packages

$ apt-cache policy libssl-dev
libssl-dev:
  Installed: (none)
  Candidate: 1.0.2g-1ubuntu4.1
  Version table:
     1.0.2g-1ubuntu4.1 500
        500 http://mirror.uoregon.edu/ubuntu xenial-updates/main amd64 Packages
        500 http://mirror.uoregon.edu/ubuntu xenial-security/main amd64 Packages
     1.0.2g-1ubuntu4 500
        500 http://mirror.uoregon.edu/ubuntu xenial/main amd64 Packages

So I fixed it with

sudo apt-get install libssl1.0.0=1.0.2g-1ubuntu4.1
  • + This solution is nice. This will resolve almost conflict problems about unmet dependencies. – christian Nguyen Oct 19 '17 at 7:37
  • 1
    I had to go for apt-get install libssl1.0.0=1.0.2g-1ubuntu4. Good tip – Tapajit Dey Oct 24 '17 at 19:52
5

This worked for me:

Unable to install libssl1.0.0:i386 due to "unmet dependencies"?

sudo apt-get install libssl1.0.0/trusty libssl-dev/trusty openssl/trusty
  • 1
    For people on Ubuntu 16.04, you'll have to run this : sudo apt-get install libssl/xenial libssl-dev/xenial openssl/xenial – Curos Dec 18 '16 at 16:22
0

Update the answer from @BHS for Ubuntu 18.04 in Dec 2018

I got the error

libcurl4-openssl-dev : Conflicts: libssl1.0-dev but 1.0.2n-1ubuntu5.1 is to be installed

Then it fixed with

sudo apt-get install libssl1.0.0=1.0.2n-1ubuntu5.1
0

This will do:

sudo apt install libssl1.0-dev

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.