I have an issue with my Ubuntu installation (14.04 LTS 32bit) on HP Pavilion DV 6000.

More specifically, my graphics cards is: GeForce 7150M / nForce630M (nvidia-304)

I installed Ubuntu via USB stick. Once the installation was completed I ran a couple of update/upgrade commands.

> $ sudo apt-get update 
  $ sudo apt-get upgrade
> $ sudo add-apt-repository ppa:xorg-edgers/ppa -y 
  $ sudo apt-get update

Maybe a few more commands, I don't recall all of them now.

My graphics card was not agreeing much with Ubuntu during the installation process (everything was blurry). Once the installation was completed and after running the update commands, I got Ubuntu to the point where the Ubuntu login screen is crystal clear and all looks fine.

BUT after I type in my password and hit enter, I get the default desktop screen with the image background but no toolbars at all. So essentially, I see only the wallpaper for a few seconds and after that, the screen turns black and nothing happens.

I can still get to the command line Alt+Ctrl+F1 and execute commands from there.

Could anyone please let me know the cause of this issue and / or how to fix it?

Thanks you!

  • Similar problem with a geforce 6150 14.04 64 bits -- use the nouveau driver as a workaround (performance is not very good).
    – ubfan1
    May 31, 2015 at 5:13

2 Answers 2


DO NOT USE NVIDIA PRIVATIVE DRIVERS, something changed since 14.04 that crash Unity. Even though you can't see the toolbars (the upper one and left one) they are there!. Try clicking where has to be the on/off logo and you'll be able to access the Ubuntu settings! and reboot!

First of all, Check (if you can access settings after normal login) in "screen settings" that perhaps a second screen is activated, even if you don't have a plugged in second monitor. It seems like the video card is working with both. Turn the second off, and you'll get more stability.

I had the same problem with my AMD64 an NvidiaN7000 laptop. Now, is running more stable on Ubuntu 15.04. If the previous advice didn't work, try this: 1- Before log in, pulse Ctrl+alt+F1, so you get the console. 2- Once on command line, log in. Then "sudo su" to obtain root privileges. 3- Then Update to Ubuntu 15.04. Some bugs with Nvidia were solved in this new version.


I had this problem too for a very long time. I have NVIDIA gtx 970. Couple things you can do:

  1. since it won't boot at all, you should try to make it boot by going to recovery mode.

  2. Once it boots, go to this link: https://help.ubuntu.com/community/Boot-Repair and follow the instructions.

I hope this helped.

  • thanks for the tip. I will try the Boot Repair and post results. May 31, 2015 at 2:44
  • But it does boot, this is a video problem.
    – ubfan1
    May 31, 2015 at 5:07
  • @ubfain1 - yes, it does boot and the issue does appear to be graphics card related Jun 1, 2015 at 0:58
  • @Jared Choi - unfortunately, the Boot Repair option didn't work for me. Jun 1, 2015 at 1:00

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .